Mooney M20R Basic Information

Hi, did this already but didn’t solve it. Monney still not available.

Don’t delete the contents of the folder, delete the folder itself. When you restart the sim (make sure you deleted the M20R folder with the sim shut down), go into the Marketplace, and it should show you a Download button.

If that doesn’t work, can you take a picture of the screen in the Marketplace showing the M20R?

For me, I see the following:

This indicates it is installed. If it has been correctly removed, you should see a “Download” button instead of “Go to Content Manager”. If you still see that, it probably still thinks it is downloaded, so double check for the existence of its folder.

How do I install the latest version? also I have just started to experience problems with the autopilot, it’s been fine until today and now when i operate it it banks very sharply top the left and wont turn to the selected heading. Any ideas how to fix that?

latest version of airplans which you bought in marketplace you get allways with help of the content manager… just click on all, then you can see below whether some content for download is available ( dont be confused with that 2,29MB package, ignore that )

but, this was so often written now… please also read what people wrote here !

OffTopic: MSFS should made this much better and inform users about new conent

1 Like

Did what you said- still out of hangar. Tries 2 updates, and 2 complete new install- always 1,54 Gb.
Only thing i wanted to do is, a simply easy fly around over “Bodensee” to the alps, to “Samdan” as i do ist sometimes in real, in a real plane. Started at 9 clock am and now it is 2 pm and not 1 inch flown.

Sorry, pls understand, what do you think. Due all respect to the work and the people who work on it, wouldn’t it be better to take the sim off the market ? update 7 is end of november, 9
spring. there are many errors that prevent the simplest flying. Picture taken after last reinstal


1 Like

Thanks yes, i seem to have figured it out using the content manage, it just says update available so i clicked download and it did the trick, the most obvious fixes are the hat switch view now work as expected which is great! also the autopilot problem I had seems to have ben fixed, not sure if that’s just random or not but either way I just did 2 touch and go’s at my local airport and they went very well, using autopilot until on finals.

JoeeAir, go to your content manager and type in Carenado in the search it will show your Mooney and should say update available or something along those lines, just click on download and it will be done.

which folder exactly you have deleted ?

Did this at the beginning and the download button still appears. I did this 2 times.
I deleted the folder: E:\MSFSPackages\Official\OneStore*carenado-aircraft-m20r-ovation*

okay…

then possible useless question, but… also restartet game ?

  1. stop game
  2. delete folder
  3. start game
  4. download M20R
  5. stop game
  6. start game
1 Like

yes, from 1 to 6 in additional restart the pc

hmm,… strange… and the folder have also content after download ? ( folder size about 1,89gig ? )

Yes, strange,folder 1,84 Gb.

okay… to be sure… former you removed

…Official\OneStore\carenado-aircraft-m20r-ovation\

not only:

…Official\OneStore\carenado-aircraft-m20r-ovation\SimObjects\Airplanes\Carenado_M20R_Ovation\

?

I have Steam , but should be in general same… last idea then, that the activation in MS-Store needs time, but not sure.

Sorry, my fault, i deleted the whole folder, sure.

now i will have a cup of coffee and have a look later, thanks.

1 Like

I don’t know why this isn’t working for you. I’ve followed this process for the 152, 182T, and the M20R, and it has always. The only difference was the 152, which is core content so it’s reinstall was a little different, and was started automatically by the sim, just like when a patch is released. The Carenado planes were both re-downloaded via the Marketplace, and both worked.

Looks like I have done something wrong as I have deleted no folders, yet it seems to have worked as I now have the up to date version.

ETE = Estimested time enroute

Wow this is a big thread. I’ve been flying the M20R all over the eastern US and have slowly been working out bugs. The avionics fix was mentioned in this thread earlier, but in case anyone missed it, turn the AI and Multiplayer aircraft to “generic” under settings. The big with the avionics turning off will go away.

I use Pilot2ATC, and the only issues I’ve been having aren’t specific to this aircraft, but more so with MSFS and Pilot2ATC…so not really appropriate for this thread.

The only thing I would like to see change on this aircraft is the altitude selection click area. I find it extremely difficult to click the knob to switch between the altitude selection and the VS speed.

This has become my favorite aircraft, which surprised me since I usually prefer business jets, and typically don’t like Carenado. I haven’t really enjoyed the Citations in this sim though.

2 Likes

And till the Turbo Porter is made my someone, this can descend like the Porter with its spoilers deployed.

1 Like