Most flight sticks incompatible with FS2020

Tried with Saitek Aviator AV8R-3 and Thrustmaster Afterburner. Granted these aren’t very new products, but they’re still USB, very popular and totally work with FSX and other flight simulators. I’ve read all over the internet of many other people complaining that their flight sticks aren’t working.

Looks like there’s only a dozen flight stick that work with the new flight sim and people on EBay are selling them for extortion prices. Microsoft should rectify this immediately!

By “Not working” what do you mean?.
If Windows 10 detects it, it should be available in FS.

One issue that many people are facing is that they are used to the old Binding method of setting up hardware.
Initially, I thought my x55 was having issues, then quickly discovered that you have to assign the input from the List. No assign the input my activating it. Which, was somewhat fun and required my downloading of the button layout of the HOTAs so I could select the appropriate Input from the dropdown.

Not overly intuative, and has caught out many people it seems.

1 Like

There’s a huge difference between “Not Working” and “No Preset”
In the case of MSFS, it’s the latter.


No preset and no way to assign controls to the stick and its buttons. In other words, not working. Yes, of course both sticks are recognized by Windows 10.

You can assign the flight controls in the control menu.

Could you expound on this. First I am hearing of this solution. What do you mean, the input list or control list?

No, I can’t. All I get is a blank page and if I click on assign nothing happens.

Instead of posting snarky comments and pointing out the obvious (go to options>control!! Yeah, like I would have never guessed that…) can someone detail the procedure to assign commands to a flight stick? All I see is a blank page under my flight stick and if I click on something on the left side nothing happens.


The way I assigned the controls, and this hasn’t worked, but on the left change the filter to all. Then select the command you want to assign, then in the pop-up click in the field, and push or move the button or axis you want to assign.

But if read @MrAdrianSW comment it seems there is another way. I would like to know more about that.

1 Like

That’s what I did, and nothing happened. :frowning:

My CH Yoke was a PITA to setup. It’s almost as if the boys at adobo have never used a MSFS product at all. Why can’t I click a button and assign it to a command!!?? Also, looks like no carb heat yet?

Just to be sure, you may have done this, click into the field to activate it, for some reason when the popu comes up it isn’t ready for input unless you click the field. Otherwise you do have a legit problem with FS2020 and your controller. Does it even recognize you controller next to keyboard and mouse?

1 Like

I’ll just say, nothing about MSFS 2020 is intuitive the way other MSFS products have been. I could have saved a LOT of time had I known that worked.

Yes, it does recognize it. It it in the list, after keyboard and mouse, but it’s a blank page and I’m not getting any control list. Even when I put it on “all”.

Report as a bug in Zendesk please, when clicking on All or Essential it should give you input options and then option to assign.

Weird thing, NOW WORKING! I disconnected the flight stick, closed the program, restarted the PC, plugged the flight stick back to the USB port, started FS2020 again and now I finally see the list of commands to assign. Still stupid though, why can’t I just click buttons or move an axis on the flight stick?


Yea, that’s still a bug :frowning:

Glad it works somewhat. I had that the first time I started it wouldn’t recognise button or axis inputs. after restart it works for me now tho

You guys know that when you select the command you want to bind, then click the top icon in the window that pops up (Looking glass, I think) that you can then just push the button/axis on your controller to bind.

1 Like

Try This Guys
FIX Joystick

I had the same issue last night. I’ve succesfully bound keys in the sim before on all of my peripherals, including Virpil thorttle (not recognized) and vkb t-rudder (not recognized). However, last night I was trying to bind get fuel or something and when I clicked on the field and the pop-up came up, there was no field to click on above the “Clear”, “Validate” etc buttons. It was just blank. I was on comms with my friend who was doing the same thing I was and he verified that I was missing the field to click on.

I couldn’t bind any command to any peripheral, including my keyboard.

Hopefully restarting the game fixes it.