Mouse Cursor Mode Toggle and simply broken update

FS2020 is simply unplayable for me. I can’t click ANYTHING any more, the control just becomes highlighted in blue and does not respond to a mouse press.

I believe it’s this “cursor mode” and so I’ve mapped most buttons, controllers and even the keyboard to the “cursor mode toggle” but nothing works. I can’t change any dial or press any warning acknowledgment in the game.

And this %#*^ repeating “gear up for water landing” audio is painful. It never turned off until you put the gear down and you get the make voice that won’t shut up. The “gear advisory” button just doesn’t click. Just highlights blue!!!

Oh and crashes. No less than 8 times today :frowning:

Worst update ever.

Go to your General Setting under Accessibility, change the Interaction mode from Lock to Legacy.

2 Likes

Seriously? I would never have found that. I have been searching all options everywhere, obviously, not there.

Any ideas why I can’t use the standard mode?

ok, so yes, that fixed it, but now I can’t get the mouse / cursor highlight mode at all, not that I think it’s needed.

Is this a setting that changed in the update?

Maybe just read the patch notes? Its in there. This new input method is really quite nice once you get used to it. Especially for VR. You can also just turn off the tooltips to keep it more streamlined. But it’s not for everyone.

1 Like

Yeah, shortly after my last post, I found the release notes and specifically about the mouse profile. I was testing it out and it was working, except I CTD several times and after the last one I’ve called it a night :slight_smile:
What specifically is “the new input method”? Is it the cursor toggle feature? Because even then, after going to legacy, I couldn’t get back into that mode. Now I know about the profiles I’ll have another play tomorrow.

Can you describe what you mean about the new mode being good for VR?

The new input method is the one where if the input is a dial or something more complicated than a push/toggle button then you click to lock on to it, and then your mouse is locked on it until you click again to unlock (and you control the value with the mouse wheel).

In VR this was always a pain as if you moved the mouse even a bit while you weren’t looking at the input your mouse would jump back into your field of view. I think this is much nicer. I can lock onto the alt select dial then look at the alt value in the MFD and see how it changes as I move the wheel.

If you put the input mode to lock (I think it’s called) - instead of legacy - you should get this new feature. There are also separate settings for the tooltips on the new input mode. I’ve left them on but I think eventually you’d want to turn them off.

What does seem to have been lost is the tooltip showing the value of an input in legacy mode. That’s a bit unfortunate - and hopefully gets fixed.

Some help on this and related issues.

1 Like

You don’t have to change the Interaction mode to get the old behavior back (well mostly).

Make sure your Mouse profile in Controls Options is set to “default”. There are a bunch of new keybinds that are needed to use the new Interaction mode and if you have any custom mouse settings, they won’t be automatically added.

Now you can get all of your tooltips and the new interactions are actually really handy.

1 Like

I’m actually grateful that we have a tooltip setting now. So I can turn them all off.

My question is why did they change the default to the new setting rather than allowing the small portion or VR users select it on their own and leaving the legacy as default.

Don’t mind my edits, just a little irritated that my Mooney M20R isn’t working.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.