MSFS 2020 Crash in VR - HP Reverb G2

You are absolutely right, as long as we stay to spend 90% of the time trying to solve these CTD problems on our own, we will continue to be frustrated.
Before making updates on the “beauty” side of the game, let them start by making sure the game works properly. And for that, bad feedback on the game in the specialized press, could push them to look at these problems of CTD.

Results of cross-tests on MSFS:

Motherboard: MSI MPG Z490 GAMING PLUS X570
CPU: Ryzen 5 3600
RAM: Corsair 32GB 3200MHz

GTX 1080 TI + Oculus Rift CV1 = 0 Crash (Over 1 month)
GTX 1080 TI + HB Reberv G2 = 0 Crash (On a day and some flights, 3 hours)
RX 6800 XT + Oculus Rift CV1 = 0 Crash (Over 1 month)
RX 6800 XT + HB Reberv G2 = Crash, Crash, and Crash

Either AMD has to update its drivers for the HP Reverb G2, or HP has to update their drivers for the AMD 5000 and 6000 series GPUs.

3 Likes

I just asked the question on a YouTube channel of a person who makes videos on MSFS with the HP Reberv G2 and an RTX 3090 if he had CTD.
A person just gave me his PC configuration and he doesn’t have a CTD

Hi, no CTD’s here running I9-9900K@5.0Ghz, 64GB Ram@ 3600 Mhz RTX3090 with HP Reverb G2

I notice it has 64GB of ram.
So these 64GB of ram, could be the solution to CTD?
Still the crash due to lack of virtual memory might well confirm it, although I did not find any messages like this on my side

EDITION: The famous Youtubeur just told me that he had no CTD with 16GB of Ram

Current System Specs:
STORMFORCE
I9 10900K (Running stock)
ASUS OC TUF RTX 3090
16GB RAM

I don’t know if we can draw a conclusion with 2 examples, but there are 2 people with Intel platforms, who do not have a CTD with RTX 3090, while DarkClown which has an AMD platform with a RTX 3090 at CTD

1 Like

While I wasn’t seeing any OOM events, my swap file was set to 4GB. I increased it to 32GB. So far I have not crashed to desktop since changing to 32GB. I need more time messing around but seems better for CTD. I do feel like FPS has still taken a big hit. Flying around Seattle I was seeing a commit size of 18GB while a working set size of 8GB in spite of haven’t plenty of free physical ram. Seems like maybe an “Optimization” was made to use less physical ram forcing the title to use more virtual. Maybe console changes snuck into the PC build??

p.s. my swap file is on a Gen4 Fire Cuda 520 2TB drive.

I’ve set the pagefile to 32GB (18GB previous) and CTD are still there. It was not full at crash. (Didn’t get the pagefile error in eventvwr)
I also set the default XMP profile to check for memory (oc) errors.

Was able to fly an hour with the JustFlight Arrow, but 15min after startup with A32NX the next CTD.
So frustrating.

Some error messages from eventvwr:

Name der fehlerhaften Anwendung: FlightSimulator.exe, Version: 0.0.0.0, Zeitstempel: 0x6040b793
Name des fehlerhaften Moduls: VCRUNTIME140.dll, Version: 14.28.29231.0, Zeitstempel: 0x5f4c66c9
Ausnahmecode: 0xc0000005

Name der fehlerhaften Anwendung: dwm.exe, Version: 10.0.19041.746, Zeitstempel: 0x6be51595
Name des fehlerhaften Moduls: KERNELBASE.dll, Version: 10.0.19041.804, Zeitstempel: 0x0e9c5eae
Ausnahmecode: 0xc0000409

Name der fehlerhaften Anwendung: FlightSimulator.exe, Version: 0.0.0.0, Zeitstempel: 0x6040b793
Name des fehlerhaften Moduls: d3d11.dll, Version: 10.0.19041.746, Zeitstempel: 0xfc177b9d
Ausnahmecode: 0xc0000005

I’ve got a new G2 here and don’t know if I should keep it or return. It’s not usable at the moment.
It’s definitely an Problem with AMD GPU.

1 Like

Still no crashes for me. I flew around London for about an hour with Live traffic and Live weather. Took off from Heathrow in the C172. Flew up and down the Tames and did some other site seeing. I then landed ILS 05 at Southend.

While in world my working set (physical) stayed around 8GB while my Commit (virtual) hit over 27GB. In the menus I was actually using more physical (over 12GB) vs in world.
it is almost as if someone decided to call SetProcessWorkingSetSizeEx when entering the world. If you continue to hit CTDs try increasing to an even bigger pagefile. I also wonder how bad this is for people not using NVMe drives.

my % total physical never got over 60%

A “brief” summary of what I have done so far:

To start, the base, a level configuration to run MSFS in VR

Motherboard: MSI MPG X570 GAMING PLUS
CPU: Ryzen 5 3600
GPU: RX 6800 XT
RAM: 4x8Go 3200MHz
SSD: 1To

1 -English (US) Language Installation
I was able to make flights of more than 10 minutes before having a CTD, I can now make flights from 1h until 3h. But I can also get a CTD after 2 minutes.

2 -Uninstall ALL Microsoft Visual C++ reinstalling the last Microsoft Visual C++ 2015, 2017 and 2019
It didn’t change anything, I still have random CTDs.

3 -Increase Virtual Memory from 16GB to 32GB
It didn’t change anything, I still have random CTDs.

4 -Stability test although I did no OC, with LinpackXtreme
Everything is OK, but nothing new on CTD

5 -Installing Windows 10 on a new hard drive, without any other program, all installed updates, MSFS is installed on a 2nd partition.
It didn’t change anything, I still have random CTDs.

6 -Uninstall the RX 6800 XT AMD driver in administrator mode, blocking the installation of the driver by Windows.
It didn’t change anything, I still have random CTDs.

7 -Launch MSFS as an administrator.
It didn’t change anything, I still have random CTDs.

8 -Community folder empty.
It didn’t change anything, I still have random CTDs. First test with the TBM930 CTD after 3 minutes starting from London

9 -Power limit increase in AMD driver up to +15%
It didn’t change anything, I still have random CTDs. First test with the TBM930 CTD after 3 minutes starting from London

The next step will be:
I read that MSFS should be installed on C
Disable HP Reberv G2 Standby
If you have any ideas, I’m interested…

If after that I still have CTDs, frankly, I don’t know what to do…

@DarkClown How do you see the use of physical and virtual memory while MSFS is running.
I read that you shouldn’t put the virtual memory on an SSD, but it’s the same thing on a NVMe, because every time you write on that type of disk, their lifespan is limited.

EDITION: 03/30/2021
MSFS Update V1.14.6.0
AMD Driver Update 21.3.2

@Gsx31 - That is a bummer. I know I was feeling pretty frustrated after the 1.14.5 update. Maybe tomorrows update will help you out too. On the up side, if you have enabled data collection, every crash is uploaded to Watson and is tracked. I would assume someone at Asobo looks at them.

@DarkClown How do you see the use of physical and virtual memory while MSFS is running.
I read that you shouldn’t put the virtual memory on an SSD, but it’s the same thing on a NVMe, because every time you write on that type of disk, their lifespan is limited.

I look at it this way; “writes happen”. Yes an NVMe and SSD have a limited number of writes. I’ve owned many SSDs and several NVMe drive and I have never had an issue. I’ve had scores of platter drives fail on me and 0 SSDs (maybe I’m lucky). I will have long since upgraded to the next thing long before I hit any paper write limit. My point is I’m not going to worry about it and I’ll just upgrade when the time comes. With PC VR gaming as a hobby, dropping $350 on an NVMe drive every 6-8 years is nothing compared to $2K on a GPU every two years.

Because I no longer knew where I had read it
Disable standby HP Reberv G2

@DarkClown Yes, you might not be wrong about SSDs and their repeated write faults.

I just saw that I had put a swap file of 16384Mo minimum and 32768Mo Maximum.
Only, it only used 16384MB.
I just put 32768MB Mini and Maxi.

I have read that Windows is very poor at handling memory, it can use virtual memory while it has space on RAM. And this is the case with MSFS.

Earlier, it was using 13.6GB / 32GB of physical RAM
And 24GB / 64GB (32GB RAM + 32GB Virtual)
It doesn’t even use half the RAM and it will use half the virtual memory, which is obviously slower.

I‘ve done disabling headset standby, CTD still here.

Did you find this value in the registry?
HKEY_CURRENT_USER \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion \ Holographic / v ScreensaverModeEnabled / t REG_DWORD / d1

I didn’t have: ScreensaverModeEnabled / t REG_DWORD / d 1.
I created it. We’ll see if he goes to sleep, I just launched a 4-hour flight. If it doesn’t crash with a CTD it would be my record (But I’m not dreaming too much …)

I think we cannot do anything about it. It’s a bug with the AMD driver, HP driver or the Sim, or both.
Until they fixed it (it’s already a problem for months now so I don‘t think they prioritize this - HP is also known for they’re bad and slow support) it’s not possible to get a normal VR experience with die G2 an RX6000 hardware.

It’s a shame but those CTD only effects a small amount of users with a special hardware combination and there are many other problems in the sim to deal with.

1 Like

I agree with you.

I don’t know if I consider it a hope, but last night I launched a flight with the TBM 930 piloted by the AI ​​from London to Marrakech, that is 4 hours of flight. When I woke up, I found MSFS still open, but displayed in 2D with the plane crashed at sea, near the coast of North Africa, with the tanks empty.

You forgot MSFS and Windows. By “luck” for us, people who have AMD platforms like Intel, with AMD GPUs like Nvidia, who play in VR or on 2D screens are affected by CTDs. Now remains to be seen if on a global scale, if we represent a small indivisible minority, or if we are really numerous, which would force them to move to find solutions. DES because it’s not just a problem. There are causes and consequences. It is not said that the AMD driver is one of the causes.

Use the windows resources monitor.

You may be familiar with the Windows task manager (keyboard shortcut CTRL SHIFT ESC)
at the bottom of that window is a link for the resources monitor. There, you’ll get more detail about memory usage such as actual physical memory used, shared memory and virtual memory (read the descriptions when hovering over columns)

An other interesting bit of information is the Windows journals. Open your Windows event monitor … (don’t know any shortcut, it’s borrowed deep in the old control panel, use the search feature of the start menu to get it quicker with the word “EVENT” and you’ll find it).
Whenever Windows runs out of virtual memory, it will leave a trace in there

1 Like

I found it, but I didn’t put the mouse over the columns, to get the tooltips, to find out what it was in the columns.

I was able to see in the performance tab of the task manager that MSFS took about 50% or less memory on the RAM (15/32GB) and as much on the shared memory. I had 30GB used in total, for 62GB.

Yet just now, redoing the flight London/ Marrakech because it enters the autonomy of the TM 930, of 5 hours, I had CTD in the center of France above an area without houses, in the middle of the fields, after 1h30 of flight.

Above England, I thought I was going to have a CTD, because the picture in the helmet was like sticky, I had black frames when I barely moved my head, but eventually, I didn’t have a CTD.

In the event monitor, I had the VCRUNTIME140.dll error that this forum is talking about on 48 topics and tons of messages.
I never found any messages telling me that the PC lacked virtual memory.
On the other hand, I have read that it is sometimes necessary to mount it, I will try, but without the slightest hope (I hope to be lied…) to increase it from 32 to 48GB.

Apart from that, I ask you the question, but I ask others, did you install MSFS on the C drive, or on another part, or another disk?

I have the game installed on other drives.
I have 2 old 128GB SSDs reused from previous PCs, and one brand new high capacity 2TB Samsung QLC drive. All of them are Sata.
c:/ windows and vmemory - old SSD
e:/ MSFS caches and vmemory - old SSD
s:/ game data - Samsung QLC

I also bought more ram to get up to 32GB ram. The game is stable now. I haven’t had any CTDs since the upgrade and Vmem settings
The longest flight I’ve done was 2hrs though.

1 Like

Anyone had luck with the latest patch??
Just played for 2h straight with no issue, than… CTD
I just want to cry alone in a dark corner.

1 Like

I just did the EGLC > LFBO > GMMX flight again with which I had the CTD.
I increased the virtual memory from 32 to 48GB

Like yesterday, I had an image that got stuck with black frames when I moved my head over an area of ​​England.
On the other hand, when I passed over the zone, in France, where I had had the CTD, everything went well.

About 5 minutes from GMMX the G2 screen went black and the GPU fans stopped. I thought about CTD, but actually no, MSFS was still running in 2D.
Before relaunching VR, I saw in Event Viewer that this switch from VR to 2D was caused by a crash of RTSS.exe (RivaTuner) that I thought I uninstalled.
So I relaunched the VR flight, until landing, i.e. after about 5 hours of flight.
I wanted to taxi to the airport, and there …
50 meters before arriving at the foot of the footbridge, the CTD erreur VCRUNTIME140.dll
What can we say, apart from 50 meters away, everything could have been positive. But hey 5 hours is already not bad.

1 Like

I have just been flying various GA aircraft for about two hours total after today’s update, after increasing the page file to 32 GB on all drives; no crashes or even any stutters, just one instance of that annoying grey-out bug, where the image in the headset goes darker on a new flight. I had to restart the sim to correct that.

I couldn’t get my rig to run with 64GB of ram, as one module didn’t want to play nice with the others, so I’m still on 32GB.

The only significant error I got in Event Viewer was this one with the game bar, which is not important.

“Application (“C:\Program Files\WindowsApps\Microsoft.XboxGamingOverlay_5.521.3121.0_x64__8wekyb3d8bbwe\GameBarFTServer.exe” -Embedding) (PID: 1908) has failed to complete a COM/RPC call because of an invalid message from server. User Action Try the operation again. If the problem persists, contact your system administrator.”