MSFS 2020 hang up in a loop by the old "press any button to start the game

MS Store version

I am really frustrated after my one week holiday I started my MSFS and after the boom and the trademark information the booting start with the old “press any button to start the game”. After pressing a button an xbox window appear with a green botton “let’s go” and it starts with a loop. Following troubleshooting has been done:

De/ reinstall “Gamining service” via recommended powershell command and also delete the folder relateded to the gaming service of the regedit.
De / reinstall " XBox Game bar" via recommended powershell command
Did a reset of Mircrosoft Store via wsreset.exe
I sign out of the store as well as of the game bar
Restart my PC
Sign in in both apps unfortunately known of this was succsessful

Afterwards I installed the new xbox app unfortunately with the same result.
Windows is up to date with the last quality update from 27.08.2021

Please also be informed that nobody has touched the PC during my holiday which lasted from 20 - 27.08.2021

The community folder is complete empty.
I truly hope someone could advise me with a proper root cause and a proper solution.
`PC specs are middle class and works fine until now.

I submit this to Zendesk ticket #121962

Hello @DLH79G .

Unfortunately I can not help you, but I moved your topic into #bugs-and-issues:performance, where issues regarding loading problems are typically found.

I’m having the same issue. REALLY ANNOYING that this hasn’t been solved in over a year. I’m on PC with XBox Game Pass installtion. I own the Premium Deluxe edition. It asks me to press any key, then asks me to verify my XBox account, then asks me to press any key, then asks me to verify my XBox account, then asks me to press any key, etc etc forever.

WHY IS PRESS ANY KEY STILL A THING?!?!
WHY ISN’T THIS A RESOLVED ISSUE?!?

Yep, same problem here after not touching the game for a week.

Turns out it was resolved by logging out of the Microsoft Store and restarting the machine. Re-logged back into the MS Store and launched MSFS from within there - works.

1 Like

brrrr not user friendly at all.

Same problem: yesteday evening I flew, today at lunch this new problem …

Same issue. Initially got around it (THIS IS NOT A FIX, MICRASSOBO) by logging out of microsoft store account, restarting and then launching game. Now even this doesnt work. Completely new issue for me, having not started the game for 2 months (before that never had this, although multiple other rubbish issues)

Is there any limit to the amount of incompetence and misery?

I’ve just about had it with this now.

1 Like

Same here exactly. Started doing this last week after almost a year of no problems. Managed to get it working once yesterday by going through an exhaustive set of twists and turns including -

Restarting / renewing / resetting xbox app
Checking and fixing xbox networking
Starting from the store and xbox alternatively
Uninstalling and reinstalling the game itself, and trying different install locations
Tweaking various services to make sure they’re running
Making a new windows user account and installing into there
Offering my soul to Satan

But again it’s stuck now. Nothing works - can’t do all this every time I want to play the game.

This must, surely, be escalated?

Had the same issue, this worked for me:
1 reboot
2 update all applications that need updating in the Windows store app
3 install the xbox app if not already installed
4 try to start msfs
5 still the same issue…
6 reboot
7 uninstall msfs using the xbox app
8 install msfs using the xbox app

1 Like

AHHHHHHHBNBNHHBNHPIO:(NHBS:IPO{:IPOJ{")!pohi3h!!{)!}(O(!

WHY DOES THIS BUG RETURN EVERY TIME THERE’S AN UPDATE!!! WHY IS “PRESS ANY KEY” STILL IN THE CODE. KILL IT WITH FIRE ASOBO!!!11

1 Like

I’m having the same issue. I have one Deluxe Edition Steam, and have NOTHING, it is not a game, it is patient proof tester. Steam do nothing, only devolution in Steam credits IRGSSS, microsoft does nothing, complex scripts that do not resolve the problem.

Shame on Microsoft and Steam, this is not a game this is a stealing.

  • theft,
  • robbery,
  • stealing,
  • burglary,
  • thievery,
  • pilferage
  • theft,
  • thievery,
  • filch,
  • picking

Check time and date both in BIOS and Windows.
If the date/time are incorrect then you see this issue.

1 Like

Ive had trouble free use of MSFS 2020 since launch day until today and now I have this same issue with the Press Any Key to Start.
Cannot get around this at the moment.

Happened to me yesterday.

I needed to start the Xbox app on PC and the said I needed to download sth else, did that. Reboot. Open app and let it run. Then start sim. That did work.

Darn Xbox app.

Had the same issue after not starting the game for serveral weeks.

Signing out of MS Store (not Xbox) did the trick for me and now I get the latest patch to download.