Msfs 2020 not running correctly (warning a running process may be interfering)

Since this morning , I am getting the following warning message at the start of MSFS 2020 : a running process may be interfering with the correct operation of Microsoft flight simulator.
my AV not running, I checked running processes with task manager and process lasso, no new process is running just the usual windows processes. sound and nvidia.
when I click OK on the message , it goes to Press any button to start screen

Are you running Process Lasso while running MSFS? There is a known issue with lasso that conflicts with MSFS:

KNOWN ISSUES (Last update: Sep. 17th, 2021) – Microsoft Flight Simulator Support (

Also a small topic here:
Process Lasso - Bugs & Issues / CTDs - Microsoft Flight Simulator Forums


I was not running process lasso while using MSFS 2020. I just tried it once to see if there is any unusual process stopping MSFS 2020 from running.

1 Like

What antivirus are you using? I found a topic on reddit with a similar issue (different MS Game though):


I use MacAfee but i disable it when running MSFS 2020 .

I have read the reddit comments and will try some of the suggestion.

Tried the AV suggestion, turned AV on, off. Still same problem.
No unusual process was running. Community folder emptied.
I did not want to do it but I am reinstalling MSFS and will see the result.

I have reinstalled the whole MSFS 2020, it took me hours and the results was the same.
Still getting the same error message.

It is frustrating.

I have had the same problem since yesterday. I played in the morning and two hours after 4 pm the same message appeared on my screen. I remembered that Xbox store asked me for an update in the morning, but that was all. I re-installed the mfs2020 and nothing.

1 Like

Hi Delcorto

Do you mean no more message after reinstall?
I reinstalled and still get that message.
I might wait till next update, in the hope it will be solved!

I still have the problem after reinstalling. I don’t know what is happening.

turn off AV means that defender will take the job…

Have you tried instead to add the game ( and may be folders ) into the exclusion list ?

I followed the reddit link from @Hester40MT and a user mentioned similar thinking.
Strange would be that in case of defeneder is active, you also run into the issue… but that defender caused trouble for MSFS is not new :slight_smile:

I believe I found the problem.
I completely removed/uninstalled McAfee AV from the PC and now the error message is gone.
I just let windows defender do the job.


I have Norton, I removed, and…nothing. So the solution was to reinstall Windows and thats was the final solution for me.

Norton… this is possible ? :rofl: … it’s hard work to get a realy a clean system in case you have one time installed this kind of “have no word for it” tools. Also the official de-installers do not what they promise…

I have the problem. On a hunch I went to Windows’ “Check for Updates” and saw a message saying that my system is not suitable for Windows 11.
I suspect that Windows Update has something to do with the MSFS problem.

Did someone solve?

I have erroe: “a running process may be interfering with the correct operation of Microsoft flight simulator…”

I have nod32, I tryed everything, remone AV, reinstall FS2020, XBOX app and the MS store, with no results!

Untill 3 days ago, all was fine!!!

Thanks for your help

1 Like

Please tag your post with #pc and/or #xbox.

Are you on Xbox, Steam or Microsoft Store version?

Are you using Developer Mode or made changes in it?

Brief description of the issue:

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

PC specs and/or peripheral set up if relevant:
i7 10k 2070 super 32gb
Build Version # when you first started experiencing this issue:

any one already have see this image?


Something on your PC or in your system is blocking access to the servers.

1 Like

on the second time the sim load fine.

so the site is ligit?