MSFS 2020 wont start, directs me to the store?

I realize this has probably been posted before, since this seems to be an issue as far back as launch for some, but I need some help.
OK, so I’ve been playing MSFS 2020 for months. Bought the premium version back in Sept 2020.
Just yesterday, I went to start the game, and it wouldn’t load, but directed me to the Microsoft store.

I went looking for answers, and tried “repairing” the the gaming services, Nothing.
I was told to uninstall and reinstall. I did an uninstall on the game, and now when I try to reinstall, it wont download.
I get an error. Not sure what to do from here.
The game was working absolutely fine for months, but now, it wouldn’t start, and now that I’ve uninstalled it, I cant even get it re-downloaded?
Any help would be GREATLY appreciated.
I had done the original install on a different drive then my operating system drive, ( Dont have enough room on my SS drive for the game, it ran fine on the other drive )
There are still folders in the drive from the game, I thought perhaps I should delete them as well, they wont let me delete them… ( i.e…WindowsApps ) Says I need permission from TrustedInstaller.
So I’m kinda stuck here. Guess I could reformat the drive?
But I really need to know why I cant re-download my game.

This sim can be fussy.

Here is a link to the support article on this problem.
Go through this, and let us know if it works out!

https://flightsimulator.zendesk.com/hc/en-us/articles/360015760660-Download-Installation-issues-Windows-Store-troubleshooting

Went through the entire process. Nothing. Everytime I try to re-download the game to re-install, it either just sits there, or I get an error.
I will try to post some screen grabs.

same here!!!

Error codes are: 0x80070424 and 0x803FB107.
After spending a few hours reading, I’m getting the feeling this isnt fixable without a re-install of windows.
I have reset the Microsoft store, deleted the store cache, ran Microsoft update, ran Microsoft store update,
I have tried installing each of the three purchases, in different orders, ( digital ownership, MSFS, and MSFS premium ) disk clean up, sfn/scannow

1 Like

This thread may also prove helpful.

OK. Fixed it.
After spending the ENTIRE day trying every “fix” suggested, ( registry, commands, resets, etc…) on about a dozen different sites, I finally just did a re-install of the OS.
I got it re-downloaded and it started and ran. So far…
BUT… whats to stop this from happening again?
I mean, I had MSFS installed since last September, it ran fine from day one, then suddenly, with no recent update or anything to blame, it just stopped, and the only fix is an OS re-install???
After spending more then 12 hours working, and working, trying every thing I could find, its clear that NOBODY, including MS knows whats happening or how to fix it.
A clear sign of a total bull**** program. Be proud guys, you got my $119, with no way to get it back, for a program that has the potential to stop working at any given time, with no warning, and no known fix.
Seems some people get lucky with trying something, most have no choice but to re-install and entire OS THEN, go through hours of download all over again.
Sad. Very Sad.

I’m experiencing a very similar issue. I have been using the simluator without issue for months. I installed World Update 3 without issue. Then suddenly for the last two days, the software won’t launch?!! It goes to the initial splash screen (World Update 3), the music is playing in the background, there’s a spinning cursor in the bottom RH corner, but right in the middle of the screen is an X-Box Dialog Box that says Let’s get you signed in, and the only option is to click a “Sign In” with XBOXLIVE button?!! I don’t have an X-Box, or an X-Box Live account. The Sign-In button is non-functional, and nothing ever happens after that. I have left the simulator running for several hours and it just sits there with the endless spinning curser. It doesn’t go anywhere beyond that.

This happened to me as well after about a month of playing. Tried help form Microsoft and Dell support but was never able to get the game running again trying everything myself, Microsoft, or Dell could. Had to do a windows re-install to get the sim working again. Was a very frustrating situation. Hasn’t happened since thankfully.

I think the windowsapps folder is a likely suspect. There are permissions inside it- its hard to remove but a rename will prompt windows to create a new one.

That’s the easyest way 2 fix the issue. This is not my opinion it’s a fact. I did a fresh install of windows then I did MSFS2020, I haven’t had any problems since. I did this on 2 separate computers

Yes the button is not clickable , this has to do with the game being in full screen mode.

Hold the left ALT key and press Enter , game goes out of fullscreen mode and then you can click the Xbox signin button…

YW

1 Like

You can not change a thing in the windowsapp folder , this folder is for windows only. if you try to own the folder and change settings in there you are compromising your windows security…
the flightsimulator ( Directory ) in there is not an directory but a Link file , a kind of text file which looks like a normal directory…

I never mentioned changing anything inside it.

There seem to be too many dependencies with this game - Windows OS, MS Store, Game Services, XBox something, maybe others. As soon as this “Error” message for the download of a critical component appears, you’re in trouble. I had to reinstall the sim twice due to that mess. I not only fear updates for the bugs they tend to introduce…

Next time do not disable windows update and ms store app update :wink:
If you disable windows update service and ms store app - you can’t download msfs and windows apps :wink:

Fly safe.

I never would have guessed that was the issue in a million years! That resolved it. Thank you SO much!!!