MSFS Application Error - memory could not be read

Thank you for all your replies, I am also on Windows 11 and come to think about it - it was only when I upgraded to W11 that I started to receive this error.


Thank you; will try.

1 Like

Fun fact: this error message didn’t crash my sim entirely. I still can move this nasty little window to the very edge of the screen and continue the flight :laughing:

And I still can end the flight like normal. Only shutting down the entire sim needs a bit more force then…


I’m getting the Read errors on Win 11, SU8.

Win10 had this a few times since SU8

Have the error almost every day for a week now. Just left LEBL (Barcelona) and 15 min into the flight the same error. Really sucks! I am on Win 10, RTX3080, i9-11900KF, 64 GB RAM. SU8. I fly the FBW A320 all the time (experimental).

Hadn’t flown much lately but the last 2x I had this happen this past week. Never had it happen prior.

I was just about to write the exact same thing. I was flying from EHLE to EHTX, and somewhere this error appeared. I was able to finish the flight though. I couldn’t find a log entry of this error.

I also started to have some of these since WU8.

This is unfortunate as it grabs the application exception and thus, my system does not create a crash dump. I can’t investigate the cause.
Next time, I’ll try to attach the debugger on it before exiting the app.

1 Like

Just tried the fix, thanks SkyVagrant. Did a successful 2.5 hr flight A32NX EGCC to LEPA with no memory error.
So I got the low bandwidth problem instead.
It seems that if by some good fortune you manage to fix something in this sim another problem will come and bite you in the a*$e instead.

1 Like

I’m glad it worked out for you too.

With regards to the A32NX memory leak I found that turning off the EFB makes alllll the difference in the world. Haha. It’s fine to use on/off, but just put it off when you’re not using it. I had no more trouble with that one ever since.

Thanks again. I’ll try shutting the EFB off when I fly next and see what happens.

also been getting these, sometimes just when loading into the sim, so not caused by any specific addon
usually its when I’m on approach to an airport but it also seems random sometimes

1 Like

Upon touch down. I think this must be the most frustrating moment to get this error. Flying Fbw in development, windows 10

…and my next one, right at the approach. This is getting a bit out of hand it seems.

Got this error also here all every third flight

So this is an issue with an airliner then right? That could explain why I never see it during the entire beta. Haven’t flown an airliner even once.

I have had it with a DA62 as well
Haven’t had it recently but that may just be because I have t done any overly long flights :+1:

joining this group as im having the same issue, the event logger shows not a flight sim error below from event viewer windows applications. I tried the above clear cache it may have worked. i get the pop-up any time anywhere no set data to repeat. I could be in the marketplace or just sitting on the ground, and a pop-up error occurs to close the app. after cache clear i didn’t get a popup for a longer period with no VR apps no extension community folder empty, so i thought this may have rectified the issue, then i tried VR running in standby with the view just on the monitor and the pop up came back.
i have reinstalled windows11 and kept my data and apps
reset flight sim
reset Xbox
The last option unless there is a cure to the problem is reinstalling msfs202, man how many times I’ve reinstalled this app its a love-hate relationship

15 11600k
gtx 1080ti latest 511.23 driver
hp reverb g2
32gb ram
500ssd that has 70gb free

Faulting application name: dwm.exe, version: 10.0.22000.1, time stamp: 0x7cbe2305
Faulting module name: DHolographicDisplay.dll, version: 10.0.22000.1, time stamp: 0xb6528c74
Exception code: 0xc0000409
Fault offset: 0x00000000000449d1
Faulting process id: 0x2920
Faulting application start time: 0x01d8578b9a6c61e5
Faulting application path: C:\WINDOWS\system32\dwm.exe
Faulting module path: C:\WINDOWS\system32\DHolographicDisplay.dll
Report Id: dd472e52-ec44-49d4-a61c-3d0edf289b6a
Faulting package full name:
Faulting package-relative application ID:

I had this problem pop up quite severe a week ago or so.

I then deleted the windows page file (cache) and didn’t experience the bug ever since. I have reported this to others too in different threats and it seemed to work for more people.

Its pretty easy to google how to clear your page file upon reboot, hope it works for others too. Good luck!

1 Like