MSFS Application Error - memory could not be read

Same issue here. Can only play the game for around 20mins before this error causes a CTD. Hopefully they fix it soon.

Anyone have tried the tool described in this video?
Msfs2020MEMORY LEAK Issue & Large Fps SpikesPossible fix & Amazing tool for memory Handling! - YouTube

1 Like

Hello, fresh win11 & msfs intall, my flight from KIAD to MMMX crashed after 1 and a half hour for the memory error. I have then installed the utility suggested in your post, i am flying since 2.30 hours flawless with no errors showing up, same flight scenery and airplane

If it keep this behavoiur for 5 or 6 flight i think that software is the workaround needed (at least for me) i did not changed the win registry as it may cause other problems

1 Like

This is similar to cleanMEM
Installed that and trying it now, it certainly reclaims ram back from other processes every 5 minutes , doing a flight from EGCC to LEPA wish me luck
I also think this audio issue is the problem so have synced my sound blast audigy fx to msfs with windows

I’m currently 1hr 6 mins in so fingers crossed
:crossed_fingers:

1 Like

MSFS memory bugs include trying to access memory that is out of bounds. MSFS has to be fixed to correct that. Nothing else will do it.

4 Likes

Yes I get that but I’m willing to try workarounds
It’s not ideal but I’m not waiting around for Microsoft/Asobo to fix it in SU10 so no harm in trying a bit of snake :snake: oil in the meantime

Well got to LEPA no problems, 2hrs 25 mins so that’s the first flight I have managed with all I did
With msfs , see earlier posts , so will keep testing and if it’s audio or snake oil or clean mem or ISLC which I hadn’t tried by the way
As a workaround if it keeps me flying then will keep it until it’s fixed properly
I could have just been lucky also but we will see

Just to note in my 32gb ram only used 10gb all flight , went up a bit at LEPA with the payware airport and AIG traffic but that’s all no more than 15gb and it hovered around 12gb on stand at palma

are you sure it will be fixed in SU10?
the interest or feedback from Asobo or Microsoft is not exactly great :see_no_evil: :hear_no_evil: :speak_no_evil:

1 Like

No I don’t think it will tbh , that’s why I’m doing as much as I can to fix it myself :flushed:

1 Like

I had yesterday once again a message but could continue to fly and push the window to the side I noticed that in a region the orthos were not loaded (white field without graphics) am currently testing a mod (advertising for the mod on board not allowed) to replace the Bing map let me know if I should receive another CTD,
The only thing that has helped me so far is the change of the graphics driver to the studio driver I get only rarely a CTD about after 6 hours of flight what I noticed but there is that I first get own massive FPS drop when panning the camera and a scratchy sound the problem was there once in a beta. So it looks like they fix bugs and then reintroduce them as if they are continuing development from a buggy build. it’s a bit crazy what’s going on at Asobo

Test .1 ups with Mapbox message already after 10 min
ok de mod is also not the solution

Sorry for stating the obvious, but take a deep breath and really thing about it.

Flight Simulator puts a lot of stress on your computer. Any marginal hardware you have could encounter errors when the sim is really pushing the GPU/CPU to 100%. Overclocked CPU or Memory that runs fine on other games may not be reliable when the computer is really being pushed to the max by this sim.

There could be multiple reasons for the error and something that fixes an error for one person may not fix it for others. It could be memory, GPU, power supply, SDD, or even multiple things at the same time.

The key to troubleshooting this issue is being able to repeat the error on-demand and then try various changes, one at a time, until the error goes away. Trying random things will just confuse and frustrate you.

what worked for me:

Put the sim into safe mode, got rid of all my overclocks and tried different memory chips. Error still occurs, so none of that was the issue.

I found the error occurs very often when I use the thumb stick on the top of joystick to switch the view from front to side to back. If I do this over and over within about a minute the sim will crash. I noticed that the power draw on the computer really spikes up when I switch the view. Both the CPU and the GPU have a huge power spike but only for about a second until things settle down again.

Because my graphics card is about 4 years old now, I decided to roll back the driver to the version recommended by the AIB manufacturer. (V 496.13) I did a clean installation of the driver erasing all the settings from the previous install (v 512.95) . I found the CTD happened a lot less often but still could happen if I kept trying for long enough.

Ultimately I found that going the Nvidia Control Panel settings and switching the power mode from Optimal Power → Prefer maximum performance, fixed the issue for me. I imagine the optimal power settings were just limited too much when the GPU was requesting full power.

Keep in mind other developers may have coded their game to recover from a hardware error like this without crashing, but in this case it seems that didn’t happen.

Best Regards,
Wapeka.

I find making sure the Windows sound output matches the sim sound output once the sim first loads, Making sure all Windows power management and screen savors are off, Never disconnect my USB joystick, Never use the Navi Map on the top tool bar, Never shut off the sim after one successful 1.5 hour flight gets me about 3-4 days of flying with no CTD’s This combination was all because of the blog writers in this forum and trial and error the last 40 days. Thank You! This is working for me. I realize this combination may not work for everyone. Also, this is pathetic we are doing more testing work arounds then actually flying!!! Come on MS/Asobo!! Fix this now! Win 10, Ryzen 7 x3700, 64 Ram, 500G SSD, AMD 6900 Merc 319 Speedster GPU, 200mps fiber Internet.

3 Likes

Nothing, for me is the same, thanks anyway for the help.

Well two flights in one of two odd hours another of 2 hrs no problems using AIG and fs realistic on FBW A320

Now I have been testing clean mem on one flight and ISLC on the other flight to keep memory in check

Also made sure my audio is synced ie: windows 11 and msfs both using same audio and it seems to be fine

Will do another flight today with ISLC installed and all other applications running with maybe the PMDG 737 to see how that goes

They guy who created ISLC is the same guy who created DDU and there are numerous you tube clips on it so snake oil or what it seems to be working for me ……at the moment as a workaround as I don’t think this is going to get fixed any time soon by Asobo: Microsoft

1 Like

I seem to have fixed my problem by changing from using the Nvidia sound driver to using the onboard Realtek sound drivers.

Previously I was using the Nvidia sound to output through my monitor speakers (over the DisplayPort). I changed to using the onboard motherboard and the simulator is now very stable.

I am curious how many other people are on Nvidia GPUs and using the Nvidia sound driver. I had previously tried changing my sound in game to match the windows output settings but this made no difference (when using Nvidia sound).

Now I have Windows set to output to the Realtek sound and Flight Sim to use the “Systems default device”.

I am interested if changing away from using Nvidia sound has a positive effect for other people.

Windows 11
AMD Ryzen 5950x
Nvidia RTX 3080ti (running latest Nvidia Game Ready driver)
32 GB RAM
M.2 SSD

I didn’t have this problem until I reinstalled the system. Sim works normally in the menu. Once it will ctd while loading, another after a few seconds on the ground. At the default aiport with Cessna it’s ok. If I load 737 from pmdg at any addon airport it crashed every time randomly. As I wrote earlier, it was temporarily helpful to change the audio output. Why it was so short I have no idea.

1 Like

Hello candycatx!
What is an NDU patch? Can you help me understand? Thank you very much!
Gábor from Hungary

1 Like

(NDU registry change) Increase performances immediatly! AMAZING! Tested and aprouved!

Hi Gabor,
Hope this helps

Best wishes

1 Like

That might be because of screwed up audio settings when you reinstalled, check windows and msfs are using same audio

Good luck

Thanks! :slight_smile: