MSFS Application Error - memory could not be read

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?


Brief description of the issue:

I was flying in At cruise for over 1 hr than this error appeared.

Never seen this before.

RAM was fine

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

PC specs and/or peripheral set up if relevant:

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

I started to have it since WU8. I didn´t even have the beta installed. Today I had it 5 times when just installing Marketplace updates. The quality of the latests game versions is pathetic…




I’ve only ever had it once thankfully. Can’t think of any reason why, just a freak occurrence

Is the reason behind most CTDs: the memory handling is wrong in game. There´s a memory leak since several months ago and they don´t fix it. Even with enough pagefile setting (as I have) you still face the problem. Memory load was around 30% when I had this error today. It happened at the marketplace window, not even while playing. I started to have problems with CTDs by this year and this memory error messages only after WU8.



I don’t recall ever getting this error. I’ll let you know if I encounter it.

Edit - I should mention that I don’t have many addons, so this could be why.

1 Like

Strange another error

I got exact same error once, then on rebooting Pc and removing / emptying community folder completely, it seemed to go away. has not come back since

1 Like

Some code in the sim or addon seems to be using erroneous pointers.


Oh right, will have to check.
Never occurred until the latest update of SU9 Beta.

1 Like

Got it today as well but on SU8, so not SU9 specific.

Mine tried to read memory at 0xFFFFFFFFFFFFFFFF, you have really gotten quite lost if you think that is where your variable is stored.

Some developer somewhere needs to put their pointers on a leash.


Thanks for commenting. I’ll have to do some further testing.
Generally I run a rather clean mods list consisting only of my destination departure and alternate airport.
Then AREX, Toolbar Pushback, Shift Z and FBW + Livery

I’ll try using the development version of the FBW rather than exp.

I’m not quite sure if this topic is about memory errors or a complaint to the construction team. I choose the first.
Tried to fly in the Italian countryside in the Rome area. Here I encountered errors such as “memory cannot be read”, followed by a CTD. This happened to me four times, and shortly after takeoff. I could not see any reason why it happened, but when I flew in my own country, Norway, there were no problems. As soon as I returned to the Rome area, the memory error appeared.
Is it possible that this error that has been seen by so many here in the forum, has its origin in errors in some of the landscapes.
Just a few thoughts.


I’ll try it today. Do you know if your PC is submitting the crash reports to Microsoft? (You could try checking the Event Viewer for this information, or Control Panel\All Control Panel Items\Security and Maintenance\Reliability Monitor)

I got this and am on Win 11, too.

1 Like

I tried flying around Rome and countryside for about an hour. No crash. Windows 10.

I had this too a couple of times today.

I cleared the Windows Cache (pagefile) and had a steady 2 hour flight after that. I just worked the register, cleared the pagefile, and then cleared the registry alteration for normal operations again. (You obviously dont need to clear it on every restart).

Edit: I also uninstalled the Working Title Garmin 1000 Nxi as there were quite a couple of posts related to that one. My first memory errors were with the Kodiak, researching that gave the WT1000 workaround first.


I’ve been using Windows 10 up to a week ago and had never had this error. I upgraded to Windows 11 and now it has started to be a regular occurrence.
I’ve always been a great believer of “if it ain’t broke don’t fix it”. I should have stuck to that belief more rigidly.


FYI I was flying around Rome in the C172 G1000 with the NXi installed. I have been using it during the entire beta without crashing.

Seems like I can join the club as well… :rofl:

Ryzen 7 2700X
Sapphire Nitro RX580
32Gig RAM

have this for long flights using the DCD Concorde recently… really frustrated when flying supersonic for a period and CTD