MSFS crash after the last update

Since the last update a couple of days ago, the game tends to crash after a period of time running.

I have tried to plot several flights from different locations, as well as different weather conditions and it continues to make the same mistake.

Does anyone else have the same problem, how do I fix it?

Hi @ErickMXC, and welcome to the forums. Sorry to see you’re having some problems.

There are quite a few threads on the forums where people are reporting crash to desktops and it seems there is no one single cause. Reports indicate that the ‘fix’ for one user doesn’t work for another user etc. Tracking down the cause is very time consuming. I suggest maybe using the forum search function to find other threads for this issue. If you wanted to be brave, even though it is time consuming, you could take the plunge and go ahead and reinstall windows. It might actually save you time in the long run. However, it doesn’t guarantee that it will solve your problem if the CTD is caused by hardware weaknesses (unlikely but possible) or driver issues.

To get you started, here are two links (Link1, Link2) to existing mega-threads about CTDs.

It would also be a good idea to check out the known issues post to see if you are affected by one of those.

For advanced troubleshooting, if none of the other fixes seem to work, then there may also be some useful information contained in this detailed thread: Community Troubleshooting Guide.

1 Like

Yeah same problem after patch released.

No workaround till now, i only try again n again after it crash. Sometimes works and sometimes it crash again.

Several issues are happening after patch update. A320 is a mess, no power or eng 1 shut down without notice.

Waiting for the patch to be fixed, I’ll back to FSX with all my addons n my PMDG 737 :smiling_face_with_three_hearts:

1 Like

I have the same issue here :c, especially with the A320

1 Like

Hi!
I have solved this problem on my computer by desactivate in option/sound the azure atc, now i haven’t sound with the atc but no crash
Maybe it will be solved in the next patch…

1 Like

Thanks GIG im gonna try with other plane