MSFS CTD after update

A couple of days ago my MSFS made me do another update. It was116gb. After it was done, I discovered I had to reload all my addon stuff. The version was still the same as before the update ( Now when I load up a plane, as soon as I click on fly after the scenery has loaded. The screen darkens, but you can still see the outside of the plane. Then it CTD with no messages. I’ve even tried the C172 without the G1000nxi. I had just got my new Honeycomb Alfa & Bravo controllers a couple of days before. I was working on programming my planes, but now I can’t get into the sim. And today my lights on the Bravo controller stopped working. They had been working. This is getting crazy, it’s been fine up till now.

John K

1 Like

Here is a summary of all the “fixes” that have been posted here on the forum.
Going through this may help.

Ensure all addons are removed from the Community folder, and any 3rd party plug-ins such as Navigraph etc., are uninstalled.
Remove any overclocks you have set up.
If you have used the Google map replacement, uninstall it using it’s uninstaller.
Ensure any third party antivirus programs (Avast, AVG, etc) are shut down.
Ensure you have an open path through the Window’s firewall.
Ensure all Windows updates are installed.
Make sure the time and zone in your PC settings are correct.
Sign out of the xbox app on your PC, and shut down Xbox app.
Sign out of MS Store App, and shut down same.
Shut down computer.
Unplug all controllers, except mouse and keyboard.
Restart computer.
Open and sign into Xbox app.
Open and sign into MSStore.
Reboot computer again.
Try sim.
Plug in controllers.

I don’t know why this is happening. I still can’t get it to work. I already had already. It loads all the way till it’s showing the plane on the tarmac and says ready to fly. When I click on it the screen goes dim, but I can still see the outside of the plane. It never shows the cockpit, then the sim just closes with no reason. And it doesn’t matter which plane.

Do you have anything in your community folder?
If you do, have you checked all your scenery for modelib.bgl files. If so rename them and update the layout.json file. Do you have anything with a “mycompany” directory? If so, rename them and update the associated layout.json files.

2 years in, and I still constantly find poorly constructed packages that could cause conflicts.

I’d try rolling cache delete.

I had to full reinstall SU7 and all the updates for s similar issue. But that did the trick.

Here is what the event file had. I also had changed the rolling cache a couple of times.

Log Name: Application
Source: Application Error
Date: 2/20/2022 2:17:22 PM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: Dad-PC
Faulting application name: FlightSimulator.exe, version:, time stamp: 0x00000000
Faulting module name: FlightSimulator.exe, version:, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x0000000000b61bb1
Faulting process id: 0x9e0
Faulting application start time: 0x01d826a59dabfcd4
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.22.2.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.22.2.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Report Id: 45a8304e-19e2-4357-9e3a-8cbee12bc152
Faulting package full name: Microsoft.FlightSimulator_1.22.2.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App
Event Xml:




C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.22.2.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.22.2.0_x64__8wekyb3d8bbwe\FlightSimulator.exe

I have no idea what it means.

Did you go through the checklist above?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.