MSFS doesn't launch - opens MS store with Gaming Services instead

Had the same problem. I play on a PC. After trying all kinds of solutions, I opened the X-Box app and saw that there was a download that was stuck. I deleted the Gaming Services app, reinstalled and the X-Box download started up. Then it was all fixed. I think when the MS Store opens and shows the Gaming Services app, it’s trying to tell you there is a problem with that app.

Issue still persists. Killing gaming services manually each time is annoying. For me this has only started since the last two Beta builds.

MrMaestrolIRL… The last few days was struggling with the Gaming Services pop-up issue too, which after much fiddling devolved into this 0x80070002 error code screen:

Then I ran across the steps in this post and followed them to the letter:

After following those steps, Gaming Services again popped up when trying to boot the sim, but then after hitting the “Repair” button at Settings>Apps & Features>Gaming Services>Advanced options then it worked… and MSFS began booting as normal. I’ve booted up now a half dozen times with no error. Your success at trying this may vary of course, but it worked for me.

Edit: To be sure, I’d hit the “Repair” button before many times (as that alone had worked for others in this thread) but to no avail. Not until I followed the PowerShell commands outlined in the linked post above did it finally work for me. Apparently the PowerShell routine disables then reinstalls a new copy of Gaming Services, which for some reason fixed my issue.

1 Like

Same problem for three days. I did everything and nothing helped. I installed a new system. Now I’m having trouble installing the simulator. He writes about game services all the time.

For me, your process was too manual. I ended up doing this:

  • Close MSFS stuck in startup.
  • Kill Gaming Services in Task Manager
  • Follow these steps to remove and reinstall Gaming Services

Reinstall the Gaming Services app on your Windows 10/11 device:

  1. Select the Search icon on the taskbar, type powershell, right-click on Windows PowerShell, and then select Run as administrator.
  2. In Windows PowerShell, type the following command and press Enter:
    3.get-appxpackage Microsoft.GamingServices | remove-AppxPackage -allusers*
  3. In the same window, type the following command and press Enter:
    5.start ms-windows-store://pdp/?productid=9MWPM2CQNLHN*
  4. Install the app on that page and select Yes when you receive the User Account Control (UAC) prompt.

Now, the Jury is out as to if this worked yet…

1 Like

Hello !

I played last Thursday and no problem at all but since saturday 19th, I got that problem too.
Since this week-end, I tried pretty much every solutions I found here (Powershell/admin ; Regedit ; Windows settin (Repair, reset etc), but none works for me (even the one stated above).

Windows is up to date.

Games Services does reinstall each time, but doesn’t recognise the game (290 Go on disk).

Xbox shows no game installed and “install” green button in my library.
But when I click on it, it tells me that Game Services could have been removed or need an update.

Don’t know what to do next.

Complete garbage that Game Services Software…

I have the same problem since the Gaming Services 10.75.13001.0 update. No remedy posted works. Trying to install MSFS again into Xbox is denied and a message says Gaming Services needs to be updated.

The only way I was able to fix the problem was by restoring a backup of my system drive to a time before I used the Microsoft Store to update Gaming Services. There is no rollback available in Gaming Services.

1 Like

same here - played without issues some days ago, now MSFS won’t start and it sort of vanishes after the initial splash screen. I too have gaming services 10.75.13001.0 installed which could be the culprit as I understand from this thread…

Edit: perhaps worth checking: I am on the Beta… perhaps the only the Beta has issues with the new gaming services?

Yes, I’m on the SU12 beta and I can replicate the problem every time I try to update to 10.75.13001.0. Are we the only ones on the beta that have updated Gaming Services and are having this problem?

I’m not on the SU12 Beta, but I have the problem anyway.

I’m giving a try to another “Powershell” hoping the fresh SU12 update could bring a solution…

Uninstalling Xbox and GamingServices and trying to reinstall them both for the X time…

Turning round and round and round…Sigh…

This is an absolute joke. Tried everything to get gaming services and the game to update, and none of the solutions work. I’ve managed to remove and reinstall Gaming Services, but when I try to launch MSFS, it still just goes to Gaming Services.

So now not only can I not update, but I can’t launch it at all!

1 Like

Xbox software can’t even finish to download…

hi, sounds exactly like my problem. I was finally left with a windows reset and then a complete re-install of all I had… Been on it for 5 hrs now… still no flying — servers are not at their fastest right now with all the updating going on I guess…

We can found a new club : The Grounded Virtual Pilot Club


See my post at 19 Feb. I have my MSFS back with no problems. Going through Windows Tech Support, NOT XBox Tech Support, and a Technician named Kevin in the Philipines, solved the problem. I waatched as he remoted into my computer, used PowerShell and assisted where required. It did require making a new local account on my computer. You can keep going in circles, just like I did, if that is your thing, or you can fix the problem by following what I did. Your choice!!

I saw that, but it’s not a solution I’m willing to accept. I’m not reinstalling windows or creating a new profile just to fix this issue.

It does NOT require reinstalling Windows, but it does require deleting MSFS and creating a new profile. I had too much invested in MSFS to do nothing, and I enjoy flying.

I’ve seen other suggestions to reset Windows, which is why I mentioned that. But I don’t see why you should need to create a new profile anyway.

I’ve got it working now as well.

It seems to me that it’s Gaming Services that’s the problem.

I uninstalled MSFS, and when I tried to reinstall it, it stopped when it was trying to install dependencies.

So I updated to Windows 11, which I was going to do anyway, and that now has allowed me to reinstall MSFS from the store.

This is such a strange issue. I haven’t used MSFS for a couple of weeks. I’ve gone through all the unistall/repair/reinstall suggestions and no luck. It just keeps telling me to install gaming services when it’s already installed and running. Looks like it’s going to be a long weekend of fixes