MSFS doesn't launch - opens MS store with Gaming Services instead

Been having the dreaded gaming services redirect when trying to run the game. Did the most recent SU6 and did a flight with it no problems in the Just Flight Hawk.

Then one day I got the gaming services on the windows store page everytime I tried to run the sim from the Xbox app.

I’ve been through everything I can to get it to work.
Tried wsreset.exe
Running the commands through the windows powershell prompt

Get-AppxPackage windowsstore | Remove-AppxPackage

Get-AppxPackage xboxapp | Remove-AppxPackage

Get-AppxPackage -AllUsers| Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}

Restarting the pc between

Totally uninstalled FS2020

Running sfc /scannow on C drive

Disabling my anti virus and windows firewall and trying to install

Windows is upto date and so is everything in the store.

You name it and I’ve tried and nothing I do will get the game to install. I’m signed in on the correct account in the store I used to purchase the game as its the only email I use for Microsoft. Its in my library but when I click install on next to the game it doesn’t do anything.

Becoming a bit of a joke really and it’s utterly frustrating why it can’t be resolved.

If anyone can help shed any light on this and something which may help apart from a total reinstall of windows then please fire away before I just bin it and be dome with it!

Thanks