MSFS doesn't launch - opens MS store with Gaming Services instead

The solution worked for me some days very well, now Im again in the Windows Store - updated anything again - sorry msfs it is anoying me. After three month only CTDs and now stuck on Windows Store more or less randomly. I have only one requirement - flying without trouble! May be it is the wrong game for my requirements. Sorry for that, but I had to express my frustration here.

Have a good weekend pilots.

1 Like

This is what I get running starting flt sim. And an endless mandatory update . Never stops endless loop

Same problem…

Go to UAC settings and drag the slider bar down to the desired security level

  • Default - Notify me only when programs try to make changes to my computer


Click ok and restart PC

Been having the dreaded gaming services redirect when trying to run the game. Did the most recent SU6 and did a flight with it no problems in the Just Flight Hawk.

Then one day I got the gaming services on the windows store page everytime I tried to run the sim from the Xbox app.

I’ve been through everything I can to get it to work.
Tried wsreset.exe
Running the commands through the windows powershell prompt

Get-AppxPackage windowsstore | Remove-AppxPackage

Get-AppxPackage xboxapp | Remove-AppxPackage

Get-AppxPackage -AllUsers| Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}

Restarting the pc between

Totally uninstalled FS2020

Running sfc /scannow on C drive

Disabling my anti virus and windows firewall and trying to install

Windows is upto date and so is everything in the store.

You name it and I’ve tried and nothing I do will get the game to install. I’m signed in on the correct account in the store I used to purchase the game as its the only email I use for Microsoft. Its in my library but when I click install on next to the game it doesn’t do anything.

Becoming a bit of a joke really and it’s utterly frustrating why it can’t be resolved.

If anyone can help shed any light on this and something which may help apart from a total reinstall of windows then please fire away before I just bin it and be dome with it!


Starting with SU6, I’ve been having all kinds of problems too.

First, something corrupted the update of Gaming Services, and I’m still not convinced it’s working right.

But at least it’s not throwing errors in Event Viewer. But, strangely, after a system restore, and FULL reinstallation of MSFS2020 from scratch, i’m still missing all of my Activity Flights - The Bush Trips, the Flight Training, Challenges, etc. Just blank screens. I checked and everything is up to date with Windows, MS Store, and the Sim. Nothing missing in the Content Manager. All of the files are in the “Official” folder in the game file structure. They just down show up in sim! Any ideas?

Start > settings > apps

Click gaming services > advanced settings> repair and reset.

Restart PC


Tried that many times and still no luck getting it to install. I’ve even gone to the lengths of completely uninstalling my anti virus which still hasn’t helped.

It’s abit of a farce that this happens and MS has no answer for it and no way of it being fixed for what seems to be a very common issue for the community.

Is there possibly some files which need to be manually removed that haven’t gone when I’ve tried to reset the app/uninstall it?

This worked!!! Thank you!

1 Like

You’re very welcome.


If doesnt help - contact ms support How to get help in Windows (

Hi all.
Success at last.
After trying all of the suggested solutions on these and other forums to no effect, I bit the bullet and tried the Media creation tool solution which some people had had success with without having to completely reinstall the sim or Win 10.
I used one specifically for 21H1 which is my OS.
Initially it is a bit daunting as it implies you are carrying out an update but after selecting ‘‘keep files and apps’’ within about 45 mins and restarting a few times it had done it’s dark reinstall and windows looked and ran exactly as before with no need to reinstall anything.
The good news was that MSFS started and ran as normal so I’m back in the air without any major upsets.

Hope it can work for those who haven’t found relief in any of the other solutions but just in case I had backed up some of my files in case it had gone awry and win 10 needed a complete reinstall.


Tried that too, I’ve submitted a request to FS support after being on live chat screen sharing with MS Support and Xbox support and getting nowhere.

Thanks for suggesting this! This is the only method that worked for me and now it’s launched and installing all the packages!

Hopefully this is the end of the problems :crossed_fingers:


1 Like

This worked for me as well. I did the same in MSFS2020 as well but I don’t think that was necessary…


No need.

I found all errors went away when i changed install drive to c: drive all works well now.

Same problem - the endless loop! Thanks to member that suggested the following FIX! I performed the REPAIR and it now works. :smiley:

gaming services/advanced settings/repair & reset

Same here. And when I try to update from the XBox app all I get is Error 0x80070032. So now we all need to be IT experts to update a game!?! Think it’s time to uninstall MSFS for good and try a better managed flight sim cause frankly MSFS sucks atm. Game of the Year? Was that title self awarded?


Those people couldn’t program the original PONG game without ##### it up.


Same issues here, I updated to Windows 11, a mistake maybe? MS Store says install via X-Box App! FS2020 gives 3 or 4 different install errors!!! I have read all the advice and still FS won’t install! I’m not going to buy this **** twice!! I, like a lot of others have purchased add-ons and now it’s like burning money and I feel like ****! Good luck to us all!

1 Like