MSFS doesn't recognize Hotas x52 Pro since update

Hi, i have a bad problem and i’m not able to fix it. Since i did install the update MSFS stopped recognizing my Hotas x52 Pro. Tried diffrent usb hubs, restarting the game, restarting the pc but its still not working. The Hotas is on and works in other games/sims but not in MSFS. Does anyone have a similar problem or does somebody know what i could do?

Like, when you move the hotas, they don’t react at all? Is your control settings only shows keyboard and mouse and nothing else?

1 Like

It did recoginze the KB, Mouse and the X-Box Controller. Looks like the game/update did delete the default profile…

Do you have any screenshot of your controls page?

My tips for the future is that whenever possible when asking questions, it helps to attach some screenshots or videos. It helps the community to be able to experience the same thing as you do, so we can see if there’s anything notable.

The reason is that, I’m still unclear on what you really mean by stopped recognising, because it could mean a multiple possibility.

  1. The HOTAS is visible in the controls and the bindings are there, but moving the controls or buttons are not working.
  2. The HOTAS is visible in the controls, but the default profile is gone.
  3. The HOTAS is visible in the controls, but the label is not recognised, so there’s no picture of the HOTAS.
  4. The HOTAS is not visible at all in the controls.

So the only way for me to be sure to see what’s happening to you, is to actually look at some screenshots or videos that you can provide. Both from the sim, or even your thrustmaster driver or software, etc.

1 Like

After i made the post i did realize that Hotas is still visible but the default profile was gone.

Then all you need to do is to rebind the commands. And you should be good to go.

Found a easier solution: Unplug the Hotas, start the Game, plug it back in on the Welcome Screen & its back to default. Made a second profile with the default settings just in case it happens again.

Thanks :slight_smile: