MSFS Doesn't Use Full Stroke of Redbird Alloy TH1

So I received the Redbird Alloy TH1 to simulate the C172 I’m training on within MSFS. Plugged it in, did the calibration. What I’ve found within the sim is that the throttle doesn’t use the full stroke of the hardware. 0% - 100% throttle in MSFS is only about 1/2 - 2/3 of the actual hardware throttle, prop, or mixture. It showing the full range of the hardware in the Control Option Axis settings, however. I’ve tried playing around with the dead zones, extreme dead zones, etc and for the life of me, I can’t get it to use the entire length of the hardware.

If it’s not making sense: the distance of the throttle (in the sim) from zero to full throttle does not match the distance of the throttle from zero to full on the hardware. When the TH1 throttle is at idle, I have to push it in darn near a full inch before it even registers in the sim 172 throttle.

It reduces the 0 - 100% throttle range and can make fine tuning RPM/speed very difficult as a tiny movement of the hardware throttle registers too much in/out in the sim.

Sadly, I tried it in X-Plane 11 and it works perfectly, so it has something to do with MSFS.

Anyone experience this or have any suggestions?

Which axis do you have the throttle bound to in MSFS? There are two, maybe three I believe.

1 Like

Indeed as raised above there are a couple of different axis binding methods which impact how the throttle works.

I can’t remember the exact names but…

one gives full 0% > 100% range 1:1 (hardware and sim exact same)

The other option can be used for alpha/beta range set ups.
This splits the range into hardware 0>50 appears to do nothing. (Would be beta range) 50>100 on hardware handles the full range of travel in sim. (Alpha)

The third option may be a bug but if you map to the RIGHT column rather than the left the sim will then duplicate that mapping into the left also…
In sim this looks like
0>25% inhibit
25>75% = full range in sim
75%>100% inhibit.

It may have been the idea to use this for beta range + alpha range + afterburner…but it may also just be a bug. I asked zendesk. They didn’t know (and none of this is documented)

I have the Throttle bound to THROTTLE 1 AXIS (0 TO 100%), Prop is bound to PROPELLER 1 AXIS, and Mixture is bound to MIXTURE 1 AXIS (0 TO 100%). When I pull or push any of the knobs, it shows the full range in Control Options under these bindings (the white bar goes empty to full). But once I hop into a plane, it’s definitely not the full range for any of them. To operate any of these bindings, the knob needs to be almost halfway in to register.

Out:


In:

Try the other option.

The one that is NOT “0-100%”

1 Like

Hmm… That did it. Now I feel dumb. Thank you very much for the help! Just made my Thanksgiving morning.

Have a good one everybody!

2 Likes