MSFS - External View - how to switch on the instruments?

Hi, with the recent update I am missing the instruments in the “external view” …
May somebody be able to advise how to switch the instruments on, please :wink:

It’s not under the assists menu now.

Assistance Options → User Experience → Instrument Heads Up Display → Minimal / Full.


Hi @MumbaiJi,

I’ve closed this topic as it’s not a bug report which is the requirement for this category of the forums. However, hopefully the advice by skypilotYTS will help you.