MSFS Fais to Start - Gets Stuck on Wallpaper

#pc

Running on Disc not Steam

Posting on behalf of my 88yo Father in Law who plays MSFS every day.

Recently the game will not load and gets stuck on a wallpaper with the spinning wheel of death in the bottom RH corner.

Any suggestions to solving the problem ?

If it is the MS store version (which I also think the disc may qualify) and there is a Microsoft Flight Simulator app available in windows start, then right clicking>more>app settings
image
might offer the opportunity to “repair” the app

image

Note: Do not click reset as that will delete all downloaded packages and the community folder if it is installed in the default location.

However the ‘repair’ option might do the trick and is safe to use.

(Note the screen shots I gave are from Win 11 but the same process works in Windows 10)

I think I tried that one unfortunately…

I have the same problem and have been dead in the water for the last week. I’ve deleted everything in the community folder and am running with everything set at mimimum and I still hang up in the middle of loading a simple flight at a small, simple airport. I’ve tried every possible work-around I’ve seen, and still nothing works. I’m now at a loss as to what to try next since my MSFS is nothing more than an icon I can’t use because it doesn’t work at all. I should say that sometime I can get into the main screen so I can access the main menu, but as soon as I try to initiate a flight…CRASH, and it hangs up for eternity. The only thing I can think of is a totally new installation, but that’s my last option which I was obviously trying to avoid.

2 Likes

dont waste your time a new installation wont work , something corrupted our profiles in the cloud . you have to create a new account for now. The only way your sim will load is with online data off

Update all apps via microsoft store app.
Also update OS to the latest version via windows update.

Thanks for the reply. Not glad that you’ve probably experienced the same problem, but glad that I’m not the only one out there with a dead duck on my desk. I tried turning off the online data and still couldn’t get anything to start. Did you try the new account approach and did it work for you??? Are we now all stuck having to wait for MSFS to come up with a solution???
Cdrbuck