MSFS flight plans take an excessive amount of time to load after World Update 11

Since this update, the flight plan loading time takes forever. I often get frustrated waiting for 30 minutes + for the flight to load and restart the sim. And then again the same story.

Right now I have loaded a thirty minute flight plan but it’s already been seventeen minutes and counting, the blue bar is full but the flight isn’t loading. I have twice restarted the sim. It’s very frustrating.

Initially, it started this way that loading any flight plan more than 30 minutes would take an awful amount of time (20-30 minutes), but a 30-minute or lesser flight plan would load in 2-3 minutes. But now any flight plan takes infinite time. If you can check my logs, view the laoding times before the sim is restarted. There is no CTD, but I have to hard restart anyway.

And it keeps displaying messages that bandwidth is too low for photogrammetry.

I check the Internet speed and it’s 6 MBps (48 Mbps) but the sim turns off Bing photogrammetry. When I turn that on when finally the flight loads, the entire screen gets grey and the aircraft - though it was on the ground - is just bobbing up and down in that grey space as if dropping after a stall. And then I have to restart the sim again.

Please do something about it.

3 Likes

I haven’t added any addon in a long time. With the same set up everything was working like a charm when all of a sudden - about two weeks ago - I started experiencing extremely long flight plan load times.

I reported this on the forum where someone from your team commented it was a bug that was being looked into (the blue bar at full but the flight doesn’t load). Since then, my experience has been the same. Extremely frustrating.

1 Like

And thank you for being there. Appreciate that.

1 Like

The blue bar fills up in one to two minutes, and then it sits there forever. The longest I have clocked it for 45 minutes. And even then the flight didn’t load, I had to stop the sim from Steam page.

1 Like

I would try the sim without any addons, or MSStore purchases, just to confirm there isn’t an addon conflict, as that can result in loading issues.
You can do that easily by starting in Safe Mode, as that only loads the base sim.
If you are not sure how to do that, there are several articles here on it, the search function could find them.

I would try and see if it reduces your startup time.

3 Likes

You also try System File Checker.
All Apps, find Terminal, right click , hover mouse pointer over “More” and choose “Run as Administrator”
type in terminal windows “sfc /scannow” (without quotes) . It will take a few minutes and will tell you if any corrupted files exist and it will fix them.

2 Likes

It worked all of a sudden without making any changes. So I made two flights. Both the times it worked like before. Flight plan loading time about four minutes.

I’ll fly again soon to see if it lasts.

Like I stated, I am always reluctant on installing add-on. The ones I have already, have been there for the last six months, and I had no issues whatsoever.

Thank you for the suggestions and advise. Will fly again after an hour and see if that’s still working.

Thanks, once again.

2 Likes

Thank you for the invaluable advice. Appreciate taking the time to write in detail.

Thank you.

2 Likes

@ZILLNIAZI17,

I have found that MSFS 2020 is extremely sensitive to the quality of your network connection and, (depending on the speed, latency, and data-rate), MSFS can take incredibly long amounts of time to start - perhaps not starting AT ALL if it doesn’t approve of your network connection.

My system is a generic PC install, (not Steam), and network connection issues or speed can make the game essentially useless.

I can understand that to a point, but being unusable simply because a neighbor is participating in a MMO game championship is, (IMHO), a design defect.  Especially since things like that are totally outside of anyone’s control,

3 Likes

You’re right.

It got stuck at the full blue bar again today for over thirty minutes. A hard restart of the application did fix the problem, but the premonition of the sim not loading just when you wish to fly could give someone a heart attack.

2 Likes

Hello @ZILLNIAZI17,

The behavior you are describing does not sound normal at all. Have you tried disabling/removing any addons you may have installed?

Thanks,
MSFS Team

3 Likes

Yes, I did remove all the contents of the Community folder but it didn’t work.

And then it worked after about eight hours with everything in the community folder this time. I am unable to deduce the problem. The Internet may not be the fastest but it’s 50-60 Mbps.

I had only a couple of hours to fly today. Out of which, fifty-five minutes have passed just waiting for the flight plan to load. Not to mention I hard restarted the sim three times during that time. And still staring at the screen with a blue bar fully loaded…

Thank you, Microsoft, for listening, and for ruining my mood and making me angry.

This is how some will celebrate your 40th anniversary.

Do you use VSYNC in fast mode in the NVIDIA control panel by chance?

If so, you have do disable it and try, or (now comes the crazy part) disable the hardware acceleration in your browser. Both together does not work currently, it seems.

1 Like

No. I have Nvidia set to its default settings. Haven’t touched acceleration of any sort.

1 Like

Have you tried updating the video drivers?

Viz.:

This one got out just today and I got notified about it. But haven’t downloaded it yet.

Downloading now…

1 Like

But I don’t think it’s the driver’s issue. The sim has been running smooth like butter with the previous Nvidia update. It’s something else and I have not been able to deduce it.

1 Like

Also, try updating/reinstalling Gaming Services.

I have seen several posts recently about weird game behaviors that were ultimately traced back to gaming services.

I had weird problems like that awhile back and what I ultimately did was to totally uninstall everything, track down any and every file it installed.

I removed all traces of everything MSFS related and slowly installed one part at a time checking after every part.

Eventually everything was reinstalled and it worked fine.

I hesitate to suggest that because a full reinstall takes days.

One more thing:
There’s a HUGE update in the pipe and chances are that everyone and their brother’s sister-in-law is downloading it.

Maybe that causes problems?

One thing you can try is to enable “off-line” mode for the game. That way if the network or servers get hammered, you can still play, just w/o the streaming scenery.

1 Like