MSFS Freeze after clicking Fly now button

Hi, I’ve just installed MSFS In my new windows. Installed world updates too.
And when I click the fly button, the game freezes on the loading screen.
I only have AA Livery in the community folder.

And did you try running the sim after removing the AA livery from the community folder?
Maybe you can also share your computer specs so that you get feedback if its a hardware issue.


1 Like

I’m having the same issues after update 5. I get task is not responding after I click Fly Now button. This is on a Windows 11 computer after running the app fine with no issues for months.

Same issue here for me.

Game Freezes directly in the loading screen when i press “Fly now”. Sometimes it is working, but i have to restart the game several time and it works approx. 1/5 of the trys.

Best regards

1 Like

Same here too.

w10 with i7, 32 gb ram and rtx 2070 8gb.

It occurs me all you describe

I had same issue. I removed all mods from community folder and restarted sim. Worked the next time. Re added all mods and it still worked fine. Lottery?

Not even a full re-install fixed it. Haven’t been able to play since SU5. It’s a joke.

Same here.
Game is stuck in loading screen 3 times after installing hotfix 1.19.9.
All threads go to idle.