MSFS Freezes since SU9 Patch

Are you using Developer Mode or made changes in it?


Brief description of the issue:

Microsoft Flight Sim program freezes and is no responsive since SU9 patch, requiring to End Task in task manager.
Does not crash to desktop, just freezes, although still have engine sound.
As yet I’ve not managed to get to taxi before it freezes.
Earlier today it all started with this issue:
Sim will not load, displays Error Code - Community Support / CTD Help - Microsoft Flight Simulator Forums

Provide Screenshot(s)/video(s) of the issue encountered:


Detailed steps to reproduce the issue encountered:

Have tried with empty community folder>
Have tried in “Safe Mode”

Build Version # when you first started experiencing this issue:

As above SU9 patch

Anyone else having same issue?
Strange how it happens in Safe Mode, so nothing to do with third party stuff.

It is advisable to use the search before publishing a post:

What has that reply got to do with my issue, I’ve read the thread and I’m not getting CTD.
Maybe I missed the point and you can clarify! Again it is not a CTD, it’s a freezing of MSFS.

After more testing, and reading another thread on here (need to find it again), I think the freezing is happening when you move out of MSFS and interact with another app, like simbrief etc. But time after doing that to freeze is different, will test more and report back, in case it helps others.

Okay, just froze without navigating outside the MSFS Window, so guess not that.

For me is the same freeze when it’s running. But it is not always at the same point. It could at begin, but it could also when I fill the flightless into the FMC.

1 Like

Yep same, no rhyme or reason! and it happens in Safe Mode, so nothing third party, just good old MSFS.

1 Like

Strangely I’ve got it working (fingers crossed). No freezing as per last dozen or so times.
All I did was change from no v-sync back to v-sync and 30 frames. So far 45min into a flight, here’s hoping!

For me is working fine again after a Graphic driver update and reset the config in Nvidia

1 Like

Glad you got it sorted, on my second flight, so all seem well now :slight_smile:

I’m experiencing this on almost every flight. I have multi-monitors and the freeze only happens after I make another application the active window (i.e. going from clicking stuff in the sim to clicking stuff on Discord). Sometimes it unfreezes, but most of the time it doesn’t, and I have to alt+f4.

I had the same, update driver of Nvidia’s solved it.

I’m running 512.77 and still experiencing this issue.

Nvidia system and reset