MSFS freezes when selecting airport

First off thank you for taking to time out to read this, could someone give me any suggestions on how to fix this sim when it comes to freezing. On the main menu i can click on everything without a problem. When I go to select a airport to fly out of that is when everything goes bad. The sim will completely freeze either on the world map and the music will continue to play, or if i am able to select fly it only loads up to about 70% then stops. I have reinstalled about 10 times and have a completely empty community folder. I have almost 200hrs logged (would be more but we all remember when they deleted our hours a while back) Thank you again any suggestion helps!!

1 Like

This may seem like a very silly suggestion, but I would try shutting down your computer (not a restart, but a complete shut down) and unplug it from the mains.

I would then do the exact same thing with your modem and your router. (Unplug both components.)

Then plug everything back in, reboot everything, and see what happens.

Nothing is silly at this point , thank you I will try that now

Thank you again but it seems like it didnt work unfortunately. Ill try it again and maybe leave it unplugged for the rest of the night and see if that makes a difference.

Drat. I was hoping that perhaps flushing the cache on your router and forcing your system to “start fresh” might be the ticket.

What version are you using, Steam or Store?

That would have been beautiful if it did worked my last flight was last month on the 8th smh. Im using the Microsoft store version.

Wow… that’s a vexing issue.

Have you tried doing a Reset from the Apps menu under settings? That will force a complete reinstall, but it has helped me in the past.

I know its bad and yup ive tried everything at this point. Ive done that and complete reinstalls at least 10 times if not more since last month.

So sorry… that’s such a bummer.

There’s gotta be an answer, especially if you’ve got hundreds of hours prior to this. Hopefully someone will read this post and chime in with a suggestion that works.

Try eliminating the Internet as a test …

  1. Start MSFS
  2. When it has started, go into the options, and switch to OFFLINE.
  3. Close down MSFS via the menu system (do NOT just X out)
  4. Disconnect Internet (unplug cable)
  5. Start MSFS
  6. See how far you get into a flight

Fingers crossed and holding my breath, thank you so much for every suggestion truly meant alot.

1 Like

thank you loading back into mfs as we speak

1 Like

Wow that worked my flight loaded straight up!!! So that means i will have to fly offline?

NO, it means that you crashing is probably being caused by the data you are getting via the Internet, or the data processing in the sim is somehow messed up…

BUT – you now have a starting point where you are not crashing.

Try turning on ONLINE, but turn off MP & photogrammetry , and Live Traffic, .
Then shut down MSFS & restart … see how far you get .

What is your Internet connection. DSL / Wire Cable / Fiber cable. What Provider.
Are you hard wired to your router, or WiFI ?

Oh ok makes since im about to do that now and im running through wifi with xfinity. I have one of those pods because my pc is in my office and the router is in my living room.

Do you have a long enough Ethernet cable to temporarily use that ? or the option to temporarily move your PC closer to the router and connect with a cable ?

ALos, there is always a possibility that you Xfinity cable signal has recently deteriorated, especially with the cold. etc. That can all be tested later.

but try first — as above

Try turning on ONLINE, but turn off MP & photogrammetry , and Live Traffic, .
Then shut down MSFS & restart … see how far you get .

Also, do you actually have a seperate ROUTER, ?
Most current Xfinity cable modems have a built in Router, with WiFi and Ethernet ports.
How old is your Xfinity Modem ? is it Rectangular, with a sloping top front, and a single Green light ?

With mp&photogrammetry and live traffic back on i was back to the 70%. That is the one i have and unfortunately my living room is too far and i dont have a ethernet cord long enough to reach it. I have those xfi pods and i thought that would help with my connection but obviously it isnt.

OK, trying just turning to ONLINE, but with MP, AI & photogrammetry OFF.

If that works, try turning on each one, one by one & restarting to see which one is causing the issue.

You said Community is empty. Do you have any ms-store purchased addons, scenery, planes etc installed.?

We will get this resolved !!!

Since it use to work OK with the xfi pods, ??? if that has not changed, its probably not a wifi issue.