MSFS has become unplayable

since my ugrade to Win11, my FPS go down to 2, yes, TWO, and virtually unplayable. i uninstalled and reinstalled MSFS, before i had it run on best settings and it ran smooth


X-plane 11?

Then go back to what was stable.


Even though my computer is capable of running Win11, I’m not changing until I’m certain there is stability with MSFS. I’m more than happy with the experience in Win10.


I was having the same issue and I fixed it. I forget how. Do you have an AMD?
I am just having issues with VR and G2 low fps, but I think the resolution is too high so i put 70/70 and it is working better now. No, the best view but better than Xp11 at high.

Well the Latest isn’t always the greatest…I feel for you but it is always a good practice to do some research before we make moves. Windows 11 has little bugs here and there outside of flightsim.

There are some VR issues but they can be worked around.

I suspect this is fixable as something is obviously messed up.

I’d do a full video driver uninstall and then install to start.

1 Like

yes, a AMD Ryzen 7

not using VR - yet - and uninstalled the NVIDIA driver as well.

it says limited by main threat, yet, the CPU usage is only in the 30%ile and the GPU between 5 and 15%

Limited by main thread, 30% makes sense. One of your cores could be maxed out. Other cores aren’t being used as much. But one spent core is as bad as 8. It will throttle the whole shebang.

By reinstalling, you might have reset some graphics settings to the wrong place.

Check your Terrain and Object LOD, perhaps your traffic settings. Those can eat CPU. See if you don’t have something maxed out that is killing one core of your CPU.

For example, you don’t process terrain LOD on multiple cores, it just utilizes one. So if it is set far too high, the rest of the computer’s cores have to wait for the limited core to do its thing every frame. They can’t go as fast as they could or they would be out of sync. So everything must be as slow as the slowest CPU process. And that is a possible clue to the source of your issue.

Does that make sense? Kinda hard to explain.

This may not be a Windows issue.

Also, make sure you are running in DirectX 11 instead of 12 in sim.

Just trying to exhaust all plausible sources of low FPS.

If you just installed Windows 11, that would seem to be the problem. But we may be looking in the wrong place. It might be something glaringly obvious in the sim itself.

Limited by main thread means that the CPU is working harder than the GPU, not that you have run out of CPU.

Have you tried disabling AMD-V feature in the BIOS?

I have the exact same performance as W10 on W11, no different. Something is off in your settings

First of all BIG mistake to run MSFS on Win11. Go back to Win 10 that is more stable, then when evrything is working fine created a Restore point. If afterwards something goes wrong then you can restore your PC back to the working state.

Can somebody recommend a free overlay that will allow me to view my cores workload.

1 Like

Ressource monitor is enough

I have used MS2020 on both win 10 and 11 and see no difference.

1 Like

Did you do an upgrade to Windows 11 or fresh install? I have seen a few people have issues after upgrading instead of doing fresh installs. You shouldn’t have issues, but it seems some people do. I’m running MSFS on Windows 11 using a Ryzen 2600 and an RX-580 8GB and it performs exactly the same as it did on Windows 10.

You could try using something like DDU to totally remove your graphics drivers and then install them fresh again, if you’re comfortable with doing that.

Another option is to visit the manufacturer of your motherboard and download the latest chipset drivers, or visit AMDs website and get them from there.

MSFS definitely does run fine in Windows 11 so somewhere an issue has crept in on your machine. If you only did an upgrade and not a fresh install you can always try the fresh install option, although it is time consuming to reinstall all the software especially MSFS.

If I remember correctly there is hardware that will just not work with win11 (or vice versa actually). Maybe your memory is too old, maybe your mainboard, maybe maybe maybe. It‘s hard to tell what‘s going on without knowing anything about your computer.