MSFS Launches MS Store for Gaming Services

yes, I had to reinstall all of it. It is really a mess of a work, that sucks. Reinstallation came with update 4, do you know wether I have to install world update 1-3 manually again or is that part of the last installation-file? It is somehow not clear to me…

Thanks, will give it a try (takes a while) and second time…

The title of this Topic is wrong. The download from MS Store is an update to a
Windows core system file.

Thanks, have tried to uninstall, but “greys” out so unable to delete. Surprised that Microsoft has not addressed this issue given the amount of “issues” reported.

MSFS will also open the MS Store app to download Gaming Services.

1 Like

Yeah but it is showing “Install” and “Installed on my computer”… Will wait for a patch. Microsoft really need to sort this, looks like many others have the same issues.

If MS Store shows “Install”, you should click “Install” and let
MS Store download and install it.

It is only an update.

The file is a Windows core system file. This is why you can’t delete it.

The Title of this Topic implies there is a new Launch which is not correct.

Should the title say: “MSFS opens MS Store App for Gaming Services”? (or would users think it is a “new” Store opening for Gaming Services?)

I guess it depends on how you read it. :slight_smile:

It is an update like all the other updates from MS Store.

The file is a Windows core system file. The software is a Windows Store App.

Correct. And MSFS will launch (open) the MS Store app to download the Gaming Services.

I would say update the Gaming Services or
download the Gaming Services update.

But it is your call.

I am not the one with the issue. :wink:

The issue is that it goes into a loop for some users where it always prompts to download gaming services even when gaming services is already installed or updated. Thus this topic.



After this Topic was being discussed, I had MS Store
download it to me. It installed immediately.

No problems at all.
I don’t have an issue.

I just went to MS Store.
Clicked “Get Updates”
It displayed “Xbox Game Bar” update
Clicked it.
It downloaded and installed it.

I had done the same thing with “Gaming Services”.

Have uninstalled and reinstalled… looks like a loop?

1 Like

Here is mine.

Then I selected “Get”

Click Install

It will not install it again.

But it remains in the Downloads and Updates list on MS Store with a “Launch” Icon.
Click and go through the same action again.
Tries to install it but does not.

Appears to be a software loop in MS Store.
Not associated with FS2020.

@Hester40MT, FYI, I forgot to copy you.

Yep, exactly the same issues… Have deleted and reinstalled with the same result via PowerShell.

Yes, MSFS unplayable for me since it only ever wants to open the gaming services page in the store.
Have uninstalled/reinstalled. scanned system files, cleared caches and all the other guesses Microsoft throw at you as solutions and nothing worked.
Maybe they shouldn’t update the gaming services app every ten minutes (at least it seems like it recently).

Same problem here, also. Have tried all the things shown online to correct the Gaming Services install but to no avail. There a a fair number who have experienced this. And the sim was working sooo well prior.

I seem to have got it working again for me at least.
Completely uninstalled MSFS, reset the ms store, reset the gaming services - this by itself did not work as now it refused to install MSFS again.
So did the following from Xbox troubleshooting ;

  1. Right-click the Start button in the lower-left corner of the main screen, and then select Windows PowerShell (Admin).
  2. In the Administrator: Windows PowerShell screen, type the following command and press Enter:

3.get-appxpackage Microsoft.GamingServices | remove-AppxPackage -allusers*

  1. In the same window, type the following command and press Enter:

5.start ms-windows-store://pdp/?productid=9MWPM2CQNLHN*

  1. Install the app on that page, and select Yes when you receive the User Account Control (UAC) prompt.
  2. Restart your device, and try to install the game again.

Then was the long wait for the download, I’m glad I have unlimited fibre internet and went to bed while it reinstalled. I have the game open right now and I am reinstalling all the extra content packages.


ive seen multiple people talk about the opening of gaming services when trying to open MSFS but mine is much more harder, when i try downloading the gaming services app it gives me an error. CODE: 0x80073D26

i need lots of help

1 Like