MSFS missing Cockpit Legacy option on Xbox

So I’ve been trying to use my mouse to control various knobs/switches on the A320neo default.

One glaring problem I’ve encountered is I can take the aircraft out of managed mode using MID-CLICK. However, to put it back into managed mode (right click) it doesn’t follow my command whatsoever. Same applies to QNH and STD on the barometer switch.

Funny thing is, it’s not really a bug because if I then grab my xbox controller and follow the same command to remove it from unmanaged (PRESS A) it works fine.

I’ve posted this elsewhere and members have said go into my accessibility options and change cockpit interaction to LEGACY.

Low and behold, xbox users don’t seem to have this setting in the menu? Where is it? Surely if you port something over to xbox we need access to legacy interactions?

Any help or assistance welcome as this is driving me crazy not knowing if it’s a bug or if I can change it in settings.

See photos of what I’m trying to describe!


I was having similar issues, but have found it’s now working for me now I have learned how to change modes. I was finding that if say a 5000ft altitude target had been set prior to takeoff, the plane if AP was engaged would appear to stick in Managed Altitude AP mode and do everything to stay at 5000ft even if I changed the value on the dial up or down. It wasn’t until I discovered that by changing the elevation it then required the middle mouse click (simultaneously with holding left mouse click to keep menu visible) or with XBox controller selecting ‘A’ to change alt (then change it with right Stick), ‘X’ to choose ‘Selected’ then ‘B’ to exit that it worked for me. To go back into managed mode you appear to need to have a flightplan of somekind though, keep that in mind, not so much on takeoff. ps there is no ‘legacy’ option that I can find either, but perhaps I don’t need to look for one now. I think the XBox implementation of choosing Selected and Managed modes is not obvious at best, and for me didn’t help having ‘N/A’ plastered next to them in that click over menu as is shown in your first image.

I had the very same issue. Agree 100%. At least I’ve figured it out now after a few hours scratching my head.