Msfs not flying

I can setup a flight but the plane (any plane) won’t power up. It keeps killing my second display then flashing on with nothing on it. I ran a verification of the files and the files seem ok. the display driver is ok but I have to restart the system to get the screens working again.

My system has a i9, 32G memory, the game is on a 1TB M.2 card, a rtx2070 display card.

Any ideas? Is there a way to uninstall the game on do a reinstall?

Are you talking about the MSFS app crashing to desktop or you can’t startup any aircraft?

The app isn’t crashing, just displaying odd behavior. The flight starts with the plane on the runway with the engine at idle, the engine doesn’t respond to the throttle control. Soon after trying the throttle the second screen goes dark and the main display blinks, the 2nd display will come back on but the windows on it have been transferred to the primary display. After this first occurance of the display anomaly, the planes engine stops and won’t restart and the g1000 screens go dark. All the switches for these items are in the on position.
I ran the verify integrity and it says all files are ok and I do have the lasted driver for the display card.

Other games are working normally.

  1. What controller/controllers are you using?

  2. Have you checked the control bindings to confirm no conflicts and all switches and axis work as expected?

  3. Have you checked the marketplace and confirmed that ALL content for your version is downloaded, updated, installed?

  1. Using the Thrustmaster TCA sidekick Airbus Edition and the quadrant Airbus Edition.
  2. Switches and axis seem to work in controls setup.
  3. Content was up to date.

Right now the next update is waiting to be applied (I’ll do that tonight). Maybe that’ll fix the weirdness.

Keyboard Control-E will start the engine (but you should not need that on flight start… there must be something going wrong indeed !)

After reinstalling msfs with no fix, I unplugged the joystick and quadrant and was able to fly using the keyboard. I reinstalled the Thrustmaster drivers and bingo the joystick and quadrant are not working and the other weirdnesses are now gone. Learned a wee bit about driver troubleshooting.

Thanks all for the helpful suggestions.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.