MSFS will not start

I’ve played MSFS successfully on my PC since its launch last year. No CTDs. No problem with updates.
Yesterday, I returned to the simulator after a few weeks away and it would not start. I used the taskbar icon as always, right-clicking to Run As Administrator and — nothing. Just a blue circle next to the mouse arrow for a few seconds and then I’m left on the normal desktop as if I’ve never tried to start MSFS. I’d read that at least one major update (possibly two) and the latest hotfix had been published since I last played, so I decided to download them. It took a while, but eventually I managed to do this through the MS Store. The updates went smoothly. At the end of the updates, MSFS was launched automatically. I checked in the simulator and confirmed I now have version 1.19.9.0. Up and running at last, I thought! I tried closing the simulator and re-restarting – just to be sure all was well. No problem. So I shut down my PC overnight. On re-booting the PC this morning, the same problem appeared. Trying to launch the simulator fails. Just the little blue rotating wheel for a few seconds and then nothing but a normal desktop. Windows 10 is fully up to date. MS Store says MSFS and all my other apps are also up to date and I’m “good to go”. Sadly not with MSFS!
Can anybody help?

This is the log file from my latest attempt to start MSFS:

Fault bucket 1823985436299323679, type 5
Event Name: MoBEX
Response: Not available
Cab Id: 0

Problem signature:
P1: Microsoft.FlightSimulator_1.19.9.0_x64__8wekyb3d8bbwe
P2: praid:App
P3: 0.0.0.0
P4: 00000000
P5: ucrtbase.dll
P6: 10.0.19041.789
P7: 2bd748bf
P8: 000000000007286e
P9: c0000409
P10: 0000000000000007

Attached files:
\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERD3B3.tmp.dmp
\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERD47F.tmp.WERInternalMetadata.xml
\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERD490.tmp.xml
\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERD48E.tmp.csv
\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERD4AE.tmp.txt

These files may be available here:
\?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_Microsoft.Flight_26793c35e0f46c7289b2a728ffd3dcf8f1e8d7_ccb71fac_4f6bc998-e2c9-4b39-9c12-2b00c782308c

Analysis symbol:
Rechecking for solution: 0
Report Id: 3eff55c5-6315-4c47-b951-95715e8fad7c
Report Status: 268435456
Hashed bucket: 54288da816ee5fcab9501917261b691f

I have the same issue did you fixed it ? Nearly the same Error message.

Check your Windows updates, check Windows for viruses, check defender…

https://www.file.net/process/ucrtbase.dll.html