MSFS2020 Still Crashes after hotfix1 and hotfix2 released on the 06/08/2021

, ,

The CTD situation gets more and more bizarre.
Before SU5 no CTDs (other then incompatible addons after WU Nordics)
After SU5 CTDs

  • after finishing flights returning to main menu, esp. after finishing activities from the menu
  • inside the world map
  • lately even when starting flights
  • after updating the CRJ from the content manager, CRJ is a notouriously special case when it comes to updates anyway

Asobo has exactly one priority right now, we can only hope they know that

Hi,

I am really sorry to hear that, this is really unfair. And it got even more frustrating knowing that you can’t do anything and they just don’t reply to you it make it
worst.

DigitalRedboy

Exact same experience here. No CTD before SU5, all your symptoms since then… I have gone back to flying in XP11 (oh the ugly weather/lighting, can’t unsee it anymore) until this gets fixed…

2 Likes

Since my last post, for the last two days, I’ve been able to fly without a single crash (knock on wood). This leads me to believe the issue may have been server-side, or at least something they could correct on their side without requiring a patch (as yet).

It’s been great, and I am again enjoying the sim.

Sadly, that didn’t work fpor me. Still CTD while loading

Please forgive me Xplane11, I should never have abandoned you.

2 Likes

you are absolutely right. Asobo & Microsoft screwed the pooch with Update 5 to the PC and it’s up to THEM to fix this mess. Do you really want to install everything all over again and go through this after each update? NOOOOOOOO

My MSFS just removed itself for my disk, when I check intregrity with Steam. Everything was deleted…weird.

Now when I try to re-download this sim…game…whatever, even the Downloader CTD. Always…just downloaded 2-3 gb…CTD.

I used MSFS since the release without any problems. Everything is current on my PC. However I am not able to install / download the MSFS again…

I have reinstalled Xplane, updated everything and reinstalled all the planes & airports. At least this WORKS.

2 Likes

MS FS 2020 is CTD (crash to desktop) about once per hour for me in regular use, usually while starting a flight. Usually one the second or third launch of a flight from the main menu.

Why has Asobo/Microsoft not built actual telemetry into MSFS so that the crash reports are automatically saved and reported.

hI,

Update VI has made it worst i am CTD faster now. I can’t use MSFS2020 it just crashes right away… Disastrous for a product that I have paid money for it, and Asobo/Microsoft are just ignoring this fact which is a very important fact that they have sold a product that is not working…How is that called, Any one know please?

Empty your community folder before starting MSFS and then choose Save Mode on startup. That will disable all your addons, community and marketplace.
If you still get CTDs after that, reinstall everthing.
Asobo will only fix CTD that occur in Save Mode, everything else is considered to be the addon makers responsibily

1 Like

Yeah, when you’re trying to do a long(ish) flight, and it crashes out halfway, it’s pretty bad. And you lose all confidence in the game.

image

Is there a log we can look at and see the cause?

1 Like

@DigitalRedboy can I ask you to do a test for me please, just trying to link a few things together.

Can you go offline (disconnect from the internet) and boot up MSFS see if you can fly as normal (albeit without any online services?

Hi,

Sorry for the late answer, I tried it is not working, message “Please insert MSFS Disk”

thank you

Really interesting suggestion, the game doesn’t crash anymore for me when internet is down… any idea why? I replaced my DNS by the google’s one but it continues to occur, I also flush them, renew my ip, …

@JoseMove You can upvote this exact issue here, the more that have this finding and provide data, the easier it will be for the Devs to nail the root cause… rather than blame the install or the PC.

been dealing with random crash to desktops as well. What I have noticed is that it’s only occuring with the Workint Title CJ4. Flew from Cranwell RAF to Basel Switzerland…the sim crashed twice, once on takeoff, once before landing…then it crashed again after I parked at the gate. Last night, I went to fly back to Manchester from Basel and the game crashed again shortly after takeoff. Did a fresh reinstall of FS2020 not too long to ago to fix a broken CJ4 after SU5 so I’m not trying to do that again. sigh

I’ll pile on here. Any plane (C172, Longitude, 787…) at any airport (large or small), VFR or IFR. Deleted cache, no cache, large cache. XBox controller, Saitek yoke/controls, or joystick. I even removed the Logitech plugin because I noticed that it kept the sim hanging on even after the crash, and I was getting “application already running” errors long after the CTD. Safe mode or normal mode. Uninstalled and reinstalled. Updated Windows. I can’t get any jet flight to even load, and the piston flights fail after 15 or so minutes consistently.
Also noticed that the couple of opportunities I’ve had to play in the pattern at a small field in a piston single, the landings aren’t counted. I’m pretty fed up with MSFS, and am anxiously awaiting X-Plane 12.