MSFS2020 totally corrupt after WU6

This is baffling. Installed WU6 and it worked fine. On Wednesday the 8th i just had a few flights to have a look how everything was working and it seemed fine. Thursday the 9th Sept MSFS 2020 was totally corrupted and broken. Would not work for love or money. The only changes made were WU6, nothing else. When launching MSFS2020 the Microsoft store APP would open. Microsoft store said MSFS2020 was installed so clicking on the LAUNCH button…NOTHING. I tried everything but NADA, nothing, niks.

I decided to uninstall the whole mess and try again. Still impossible to install. I just switched my system off. Today 10/09/2021 after booting up the system I went to the Microsoft store and low and behold on the MSFS2020 APP it said Install…so I did. 131.74Gb and 6.5 hrs later its been reinstalled.

Now the wierd S**t starts. On opening the drive where MSFS2020 is installed …this


Where is the users folder???
lets try WpSystem/ all the numbers/AppData/Local/Pakages/Microsoft.flightsimulator/

Inside “Packages”
how is this possible, as it was not there before

Anyone got any ideas?

1 Like

All these updates are getting worse not better. I am still baffled how after an update it all became corrupted and was unusable. And where or what happened to the USERS folder after installing from Microsoft???

1 Like

I have been scratching my head trying to understand how so many users can have a good experience with the software (runs fine every time, good frames) while many others can’t get it started or CTDs. I don’t know of any other software that behaves like this, games or productivity-based. Maybe it’s the ‘live connection’ that creates issues.

Wish I had some answers to help.

1 Like

Never had this before EVER until WU6

With all the Flight Simulators i have had since the beginning of the 90’s, never encountered this much agro as with MSFS2020

3 Likes

I don’t have an answer to your main topic, but for that pop-up specifically, it was in the release notes for this update.

So what are we saying?. Microsoft is happy enough to take their cut of the addons sold on their Marketplace for MSFS2020 but dont give a sausage if it is compatible or not with MSFS2020. I have said in previous posts this was the case. I rest my case.!!!
:unamused:

2 Likes

Tip: if you change your title, more help may be interested to come in here. You have a D: install, that always gives issues with complete reinstall. Reinstall should go to C.

Does it work now ? You show a screen shot… this box…

Q: what happens if you just click to Safe Mode, leave the sim and start again ?

Have you checked usercfg.opt ? Bottom line of it ? The “Official\Packages” must point correctly.

Again, keep in mind MSFS prefers to install on drive C: not somewhere else !

1 Like

Nice locks on those folders.

PACO572

If you believe that your update of MSFS 2020 is “Corrupt” , the do a 100% uninstall, and re-install it .

I have always found that a complete re-install when there is an Update, “seems” to result in a more stable system, than just doing an update.

I am not saying this IS A FACT, or anything is necessarily wrong with the update process, but it just seems that a RE-INSTALL works more reliably, from MY personal experience.

Having said that, you do whatever you feel comfortable doing (as will I )

1 Like

Had the same message and pressed continue. What I found was some of the downloads were only partially installed.
Installed the missing or partial files.
Now it is working with other issues like ATC, Altitude setting not working, Autopilot and others.

ASOBO should only work on bugs.
To make this a stable platform developers must be pulling their hair out.

Stop all other project like world update, aircraft and stop advertising items that don’t work like the Market place.

4 Likes

Try running this free unlock program first before uninstalling UnLock IT Free - Unlock a File or Folder Locked by the System

To all the folks who have commented. MSFS2020 works fine after the MS strore install. I have the DVD set but decided to install from MS instead. I want to know what or why the USERS folder is missing. I’m baffeled by this.

The files are not locked. They have a lock symbol on them but considering all the problems I have encountered I am not at all surprised. Ask Microsoft or Asobo, but they would not know either.

1 Like

Thank you for this. Although I knew these folders were not locked but used the program you suggested and checked and the program confirmed the folders were not locked.

It was corrupt and I did a complete uninstall and reinstall and the top 3 pictuers I have posted were the result.

1 Like

With an empty community folder, and no external simconnect programs running ??

that will be down to all the mods they have installed and expect asobo to ensure work lol

I had this today. My sim shutdown just fine last night. I opened the sim as normal, took off from Liverpool / England and CTD :rofl:
You can’t make this stuff up…

Maybe the question really is

Why is WU6 working so badly for some, but so well for others.

Personally, from all the posts I have read over the past year, it seems that not all Computer systems are equally “STABLE” - and MSFS is a great benchmark for the stability of one’s Computer system, both the hardware and the OS software, as well as any other program installed and running at the same time as MSFS.

The reason for the simulator being in a new location is because the installer did not recognise that your existing version was installed.

The most likely reason for this to happen is that for some reason, the installer could not see the Usercfg.opt file.
This is where the location of the installation is stored.
The installer is entirely logical and if it either cannot see that entry in the file, or it looks at the location that is stored there and there is no copy of MSFS, it will then install the entire simulator.

If you do not intervene, it will install it to the default location, where you now find it.

1 Like