Multiple problems purchasing Waco in marketplace

Some weeks ago I tried to purchase the Waco via the marketplace but on pressing the buy button my computer rebooted (many times of trying). Placing a ticket did not solve anything and I forgot about the purchase ie I gave up trying to buy the aircraft.

Last night I tried again and amazingly It allowed the purchase to proceed until the download started and then it crashed my computer again.

This morning I find that the aircraft is in my contents list as uninstalled and after a lot of crashes I downloaded it but then then an update was needed and although the update shows that the patch is decompressing nothing happens and after a few minutes my computer crashes.

The frustration level is unbelievable .

Maybe try reaching out to someone via Zendesk for this, if it’s a refund / payment issue, there is also an option to contact Xbox game support.

Sorry I should have come back on this as it was sorted through Zendesk quite a while ago.

Closing as resolved by OP.