Mute ATC voices

Steam
No dev mode
SU7 and before.

It’s not a SU7 bug, but for me it’s getting worse : the ATC voices becomes mute at almost every flight, Azure or not.
You can only hear “your” voice.

I can only agree with that.

  • now and then before SU7
  • first flight in SU7 and then at the end of the flight only my voice or copilot (the answers) from ATC cannot be heard.

Exactly same issue here… !!! Please fix this! Thanks you

Today I flew the same route again (KIAD-KBOS). This time I got the ATC up to landing.

But from my point of view, the instructions for landing in KBOS were not how they should be.

  • ATIS (MSFS) Wind 330/15 (300/06 in REX Weather Force - not active) with notification of landing and take-off runways 4L and 4R (not necessarily the right ones for 330 ° wind).
  • But I would get 33L clearance from ATC.
  • On landing 33L the wind in PFD was 306/13.

I think Asobo still has something to do here.

What amazed me most was the difference between the approved runways in ATIS and the approved runways in ATC.

Yes, ATC isn’t accurate, for the least I can say…

I have the same problem

I uninstalled msfs2020 and reinstalled. I didn’t solve the problem

Existing thread on this issue is here. Please vote.

It appears to be related to Azure as you can get visual/text version back by switching off Azure. You can also reduce the frequency of ATC dropping by switching to manual ATC (yes it’s a pain having to hit ‘1’ all the time to respond, but ATC audio rarely drops for me in this manual mode.)
Hopefully the underlying issue gets fixed soon as it’s a real pain.

Problem solved. I installed the English (United State) language pack

Can you elaborate? Platform, o/s language pack in windows/XBox etc? I’m confused. Does ATC audio return permenantly? We need more details.

Operating system Windows 11 pc package English language ( United States). Now it works properly

I take it you are not changing your region, and just adding in a language pack? I’m running on windows 10 & have English (UK) as default but English (US) available so I’ve just downloaded it along with ‘speech’ option too, will report back. I don’t necessarily want to switch default regions though.

I’m in Europe Italy. I had the Italian language pack. I added the English package (United States). I repeat now everything works correctly

1 Like

Thanks for sharing. I’ll give it a try. It may take a few flights to prove / disprove though as the bug is so random in nature. It was happening to me originally on XBox too (when I still had one), but he same regional language thing could be at play there too.

Well I just had a two hr flight LSZH->EGPH with no ATC loss after doing what you suggested. Usually I’d lose ATC at some stage on a trip that long. I will keep trying this on flights and see if it stays fixed. Thank you for at least giving me hope that there is a relatively easy workaround. Maybe some other people with this issue should confirm this workaround in parallel.

Forums exist for this.:+1:t2:

1 Like

Update: Now 3 flights in and no loss of ATC audio after windows 10 US language pack install. This is very unusual for me I would normally have had an ATC drop by now. Fingers crossed this works, will keep testing.

LSZH->EGPH 2hrs NO LOSS OF ATC AUDIO/TEXT
EGPF->EGLL 1hr NO LOSS OF ATC AUDIO/TEXT (had a brief Azure offline/now reconnected warning)
EGLL->LEMG 2hr 25min NO LOSS OF ATC AUDIO/TEXT

No loss either since two days, BUT WITHOUT installing English package US (Windows 10) because it was already there…
So, it’s a Azure issue ? Wait and see…

Are you sure it’s already there? When I went to look it listed English (UK) and English(US) next to one another, but I clicked on English(US) and found that it still needed installed (there’s settings to install for language, speech and handwriting, I installed them all). If it’s installed as a 2nd language you get the following in your windows taskbar.
win_lang

Azure is defniitely at play too as is evidenced by turning it off to get the text back, but there could be something else at play. I’ll continue to assess.

Well there goes that, 3rd flight of today from KSEA to KLAX and I’m 20 mins in and ATC has gone mute/quiet with no text again. Very annoying. Text retrievable by switching Azure off under sound options. It’s definitely online/Azure related I think.