My 2070 SUPER 4K settings and suggestions - episode 2

I can’t help you much with this because it is highly hardware and software dependent, that is what exactly is on your own system.

In general with similar hardware and software you’d expect similar (or close) outcome. What you describe looks more like an outlier performance and this begs the question indeed.

Win10 is smarter than previous Windows in terms of process, resources and scheduling. Drivers are complex too but they operate within known hardware characteristics/limitations and known APIs. With this knowledge you’re better prepared to understanding what it is each driver setting is mostly doing.

Also, some settings could be misleading like Multithreaded Optimization. In your opinion what would you expect this setting to do?

For in-depth understanding of the current problems and solutions about multithreading and GPU I’d recommend this article:
Understanding DirectX Multithreaded Rendering Performance by Experiments

And this one published a year before (mostly explaining the same with some variations):
Performance, Methods, and Practices of DirectX* 11 Multithreaded Rendering

Even if you’re not digesting all of the article, reading the first chapter (introduction) will certainly give you a clearer view of what it is your video card is doing in regard to rendering the game visuals

So now back to my question, what it is this “Multithreaded Optimization” is really doing?

I’ll give you my own understanding which is not what you’ll find in searching online: this has nothing to do in leveraging multi-core or HT for the video card driver so that you get additional performance. This has to do in providing a safety net for older games which were not coded for multi-threading properly. In general you better leave this setting off for better performance with modern games, and on for older games.

Having said all this and back to your question, I’d tend to say:

  • first and foremost don’t try outsmarting your system. This means in particular: don’t change process priority at all, leave it normal to get started.
  • Then you might want to review the Freesync settings and see what about disabling Freesync (if there is any such setting on the monitor itself) or at the NVidia CPL level otherwise
  • Then disable game VSync, because my settings are recommending using NVidia CPL Vertical Sync FAST which is probably not best with Freesync.

These are just starting points worth comparing with.

1 Like

Thanks for your response. I really do appreciate you taking the time and I will continue tinkering. I will try to see if I can disable FreeSync as you suggest tonight.

Regarding Multithreaded Optimization, I’ve played with that setting on/off/auto and haven’t really seen much of a difference, but this may be due to vsync obscuring fine tuning issues.

Also, regarding giving the process flighsim.exe process high priority, I tested this as well. For some reason, in my configuration, setting it to high does seem to help smooth things out. Again, if I can switch vsync off, then maybe this setting won’t be necessary.

This might not seem logical but I’m just going by repeated testing results, not by logic. :slight_smile:

So I made a breakthrough last night. I found something that I’d overlooked before. In NVidia CPL, not in the game settings, but in my monitor configuration, my refresh rate display mode was set at 60Hz. When I changed this to 100Hz, I was able to run the sim with all of your settings. A stupid thing I overlooked. Anyway, it’s still not super smooth, but at least I’m not getting the annoying flickering and I can go from here. Now that Vsync is off, I’m getting 60-70fps at 3440x1440 in a non-congested area. My next step will be to try the older 446.14 drivers. Is that what you’re still using?

Thanks!

This sounds great! If you don’t mind I’ll add this info in my OP with proper reference.

Is this the setting in Display > Change Resolution > 2. Choose the resolution ?

I’m currently using 456.55 and my NVidia CPL settings still apply (I’ve compared the different settings combinations on this driver again)

Yes, by all means, please include in your guide. You may also want to remove your reference to the older 446.14 driver.

I am not home with my computer right now, but that sounds correct, yes.

I’ve now updated my post!

NB: there was a link to an update at the end of my post explaining I’ve now validated these settings with Win 2004 (GPU Scheduling on or off) and 456.55 drivers. Just to make sure the information is not spread out I’ve now consolidated both posts into the 1st one.

1 Like

Great! Now that I’ve got the refresh rate thing straightened out, I’m going to go back through your post with a fine tooth comb to make sure I haven’t missed anything.

1 Like

I currently have a 2070S running on 2K- GSync Monitor aswell. I have gone through your guide, and have all the same settings as you have explained. With all the tweaks I am still getting only 30FPS exterior and about 20FPS interior views. GPU is running only about 50-70% load.

Any ideas, for no FPS increase with the settings tweaked as stated?

I can’t really tell or assist much with these matters but offering some advices. However when fps are not changing while changing the graphics settings it could be because your system is CPU limited. What CPU are you running with?

Ryzen 5 3600x, what’s odd it previous to the Japan update I believe I was running 60/70 frames on average. Just recently do I seem to be having major frame / stuttering issues.

This should be a capable CPU when using reasonable and capable settings. Do you mean regardless of trying my suggestions, you were getting these fps issues recently?

If so, could this be you’ve updated your NVidia driver and this is the main factor to the loss of fps? I’ve validated my settings with at least 2 drivers: 446.14 and 456.55

Since you have a Gsync monitor, have you made sure to also review the monitor refresh rate in the NVidia CPL like indicated in my post?

I did recently update my NVidia driver, I will verify. My monitor is set up to max refresh 144Hz on the NVidia panel as suggested in your guide. Maybe be a driver issue. Is it possible to revert to the last driver used or one current one you have tested with these optimal settings?

hello i bought a 2070 Super recendly and tryed out the guide directrly because im following it since long time and upgraded from my 1070 and the games looks on high settings Awsome!! before i had 4k native on the nearly lowest settings to get smooth fps with my 1070 and now with the 2070Super on high its breaking my mind and i have stable 30 fps ( limited by myself) and even at busy areas nothing changes

1 Like

Thank you for sharing your experience and enduring patience! I’m glad this is helping you get a better experience too!

Hi @CptLucky8, would you be able to explain more why you selected Low Latency to “on”? Reading up on it, seems it requires more CPU processing power? Seems backwards to me if we’re trying to load up the GPU more?

I will say though, in my own testing, Low Latency does seem to reduce the micro-stutters I get even at decent FPS.

So you definitely have my thanks!

1 Like

In my initial post I was saying:

What I’ve realized is that if you set the simulator to 60 fps it ends up rendering for example in average 55 fps (60-a). But if you set the simulator to 30 fps it won’t render to 30 fps but around 27 fps (30-b), even though it is capable of rendering at 55 fps. In other words, by the time the simulator renders the frame and by the time it displays it on the screen, there is a ‘synchronization’ point which prevents rendering fast enough to reach the maximum fps limit you’re configuring.

Any game capable of rendering at 55 fps (30+c) is definitely capable of rendering at a fixed 30 fps, instead of (30-b) but it seems it is not the case with FS2020. I’m not sure whether this is a bug in FS2020 ‘present’ logic, or a limitation because they are using DX11 or anything else, but I’m sure it is not normal.

Otherwise, if you’re ‘buffering’ the rendered frame, you also need to store them in VRAM and this adds up in 4K. These buffers which must remain allocated will prevent the simulator from loading up all the resources needed for one frame (potentially) and will therefore cause the simulator to stream vertex and texture data per-frame. Therefore I’ve chosen disabling as much buffering as possible in order to free up some useful VRAM.

The overall combination is working good for this card because it frees up enough VRAM while not loading it up too much with the balanced rendering settings, and in effect, I rarely notice the simulator needing to stream data per-frame.

In most rural and empty areas you have room to raise some of the settings if you want, and in urban dense areas fps will drop as expected but not much.

The only drawback I’ve not found a workaround yet is that if you’re for example flying and looking down the aircraft vertically in external view over autopen buildings (I test over Nice - LFMN), you can feel micro hesitations when looking at the buildings and scenery passing by beneath the aircraft. It resemble a film which is skipping a frame from time to time (think a dent in the rotating wheel skipping the film stock hole in an old movie projector). It is however barely noticeable when looking from the cockpit or down even at 75 deg angles.

This effect is most likely due to the ‘fast’ sync and my hardware trying to push up, but conversely, this might be proving these settings are the most efficient because the CPU and the GPU are pushing as much they can.

[update] This is judder and you might want read the new Monitor Settings (Freesync/G-Sync) topic in the 1st post. It you do have a compatible monitor you can eliminate judder with this!

And I thank you for sharing you feedback, it will certainly help others too!

3 Likes

Wow! Thanks for the write up! Absolutely amazing!

I’ve definitely seen the microstutters that you’ve described.

Given what you said, I get that disabling vsync makes sense, but, does that also hold true for frame limiters? Like I have Nvidia CP set to frame limit to 30. My 4K fresh rate is 60, but I can only get to 45 or so max. Would disabling the frame limiter reduce stuttering? I guess I should just test it LOL.

Thanks for dealing with an ■■■■ retentive performance geek. :joy:

Thank you for your kind words! I don’t know the answer but I’m looking forward the results of your tests!

I’m not seeing any difference in stutters if frame locks are on vs off. It seems in my case at least, the more I can load up the GPU over the CPU, the smoother sim I get.

1 Like

Not sure what I’m doing wrong but on my PC I’m only getting 19-20fps. 4K at medium high preset. Ryzen 3700X with 2080 Super, 16gigs Ram and all SSD. Should be better right? Latest FS update as of this morning. Any advice??