My CTD´s was fixed by closing explorer.exe

Finally… after countles of hours testing my hardware, different windows versions and also a YAARRR version of mfs2020.

This post

fixed it for me.

I use the Microsoft Store version of mfs2020 and all up to date version of MFS2020

In my pursuit for ruling out sources of error, I in desparation tried the yaarrr version of mfs2020 to test if there was any difference in stability.

Normally I would have multiple CTD´s during install, in menu and in flight.

Yaarrr version worked flawless, no ctd´s anymore. I could fly for 15-25 hours and this went on for days while testing.
Yarrr version does not uses internet so NO bing maps/Online features BUT the sole purpose was also to rule out hardware related CTD´s.
So I could conclude that :
My hardware was not the culprit og my CTD´s
Yaarrr version is based on steam, could this be an issue with ms store
Yaarrr version runs offline so could this be internet related ?

So I went back to testing the MS store version with offline play but CTD´s where back.

So i tested like 4 different windows 10 vanilla installs and 4 versions of windows 11 but still CTD´s

Until I saw the fix with killing ■■■■■■■ explorer.exe in taskbar.

I know that CTD´s can have root in so many different scenarios but for me this was all related to this single process running.

It is a versy easy fix so try it and send some love to Zixxstar for finding this.