My game keeps crashing every time it loads

It’s not the setting problems, it’s a bug. They need to fix it soon.

2 Likes

yeah, its not even on the known issues page for some reason even tho lots of ppl are havin it

1 Like

Same issue here. Managed to get into the tutorial flights, however it crashes back to desktop at some point anyway. With a normal flight (via the globe so to say), click on fly, loading screen shows and crash to desktop before it can complete the loading, no error messages. This is getting hugely frustrating to say the least…

With regards to the disconnect form internet before clicking Fly: doesn’t work for me either…

I’m having similar issues but mine crashes at the same point but not to desktop instead the whole system crashes and then the pc is rebooted. Happens again and again and then sometimes it will just work. Tried closing MSI afterburner and I think it helps.
PC spec:
Intel 9900k
32GB Ram
GeForce 2080ti

Do we have a fix for this as this happening tom as well

I got it to work by doing a fresh install of the game. It was fine for the few hours I played. Went to bed fine. Now, its happening again, on the same screen. Its clear its not an issue on our end, then.

I did:

  • fresh reinstall
  • different drivers
  • disconeccting internet
  • changing sound output
  • run as admin
  • different hdd
  • deleting rollingcache, usercfg files
  • disconnecting any usb other than mouse and keyboard

still crashes at the same place

5 Likes

Same. Smh.

I’ve had the same problem.
PC completely crashes at the same point every time.

Then its clear this is a bug on microsoft’s side and not on ours.

2 Likes

Hmm. I updated drivers and ran the sim with administrative powers, and it worked. I suggest others to try this, as it worked for me.

What are your specs?

Same here! Now it won’t let me back in again…

What drivers did you update?

Same here. DId everything you mentioned and disabled overclocking CPU/GPU as well

1 Like

Same here. Halfway through the cessna picture and music cuts and back to the desktop. So far unplugged my logitech joystick, updated nvidia drivers. Deleted and reinstalled visual c++, disabled all other programs including my antivirus, deleted and reinstalled entire program…i know its new, but its severely frustrating. Nothing works or has made any difference whatsoever.

6 Likes

It has crashed on me twice this morning. Once when I was ready to take off and another time when I was doing an approach. Both using the TBM 930.

Guys, I suggest you to create a bug report at the Flight Simulator Zendesk website (on “Submit a request”).

The FS team is doing a triage of the most common issues and ours is not included :pensive:.

Same thing happened to me - good to know I’m not alone. I submitted a ticket with crash reports. Hopefully it get sorted out soon.

Its happening AGAIN for me.