My game keeps crashing every time it loads

This fixed it for me the first time but when I relaunched it didnt work.

Same here…

Crash to desktop without error message is a bigger thread about it we should all go there

I finally got my game to be stable after having a ton of problems. I had to remove msi afterburner entirely from my system. I used DDU from 3dguru to remove all traces of my video driver and then reinstalled the newest driver from nvidia. I have played a 6 hour session after I got it running and think that was enough to call it stable

1 Like

No such folder under AppData

Still no response from microsoft. Still can’t play. Has anyone had any luck?

1 Like

I was able to pass the loading screen by disabling my dedicated NVIDIA card and running with the onboard Intel HD graphics card.

The game is unplayable with the Intel card (~5 fps), but at least I can see that the problem is related to the GPU.


Any luck yet? im having same issue

This worked for me, anyone knows a fix to get it to work with Nvidia?

A fix that worked for some people was using nvidia control panel to limit fps to 30 fps

Here are some workarounds that I tried last night but none of them worked:

  • I updated my Intel onboard card drivers (I was using a 2 yr old driver and I didn’t even know it was possible to update them)
  • Entering the game via the onboard card, I tried to change the graphics settings (V-sync on/off, Maximum FPS 20/30, Screen resolution, Graphics Low to High, Anti aliasing on/off, etc.)
  • Some users on Reddit suggested to make a clean install on the NVIDIA drivers using a software named “Display Driver Uninstaller”. You need to reboot Windows, enter on safe mode, remove the drivers, reboot again and install the last NVIDIA driver. No luck for me.
  • Also, after all this I completely downloaded and reinstalled the FS2020.

I think we should contact support on this since we’ve figured out the issue

Im sorry to say that FS 2020 is crashing almost every time it starts up. It doesn’t always crash at the same spot. Sometimes its when loading the sim, Cant get past the mountains screen when loading. Other times i can get to the options menu. Only once have i been able to do a short flight. I have shut down all other programs when playing, updated GPU drivers, made sure windows was up to date, game mode on, run as admin, increased virtual memory and updated xbox apps. Hoping there is a fix soon. :frowning:

Mine crashes at the same spot which is the Cessna 172 loading screen right after the updates check and this same issue has been reported by some other users. I was able to pin it down to my dedicated graphics card and a faulty dll. The dedicated gpu is unable to be used and then the D3D11.dll becomes faulty and the sim crashes. I know what the problem is but there is no way to fix it because it is not at our end.

Hopefully a patch from Microsoft comes out soon

Chek if your user folder have a special character like Á ö Í. I resolve that error copying the appdata folder in the new folder that creates MFS, similar to yours but without those special characters and paste in your user folder.

Just solved this issue. After that can I play training etc but no world map. I think the folder is still a problem for that part of the game. I hope microsoft fix that. Will be annoying if have to use another user just for play this.

No special character at all. The profile name is “tales” thats it, so that is not the problem.

1 Like

Hey guys and gals, After multiple installs and crashing to desk when I pressed “Fly”, I read an testing review of vid cards with this game.

Essence of review: turn of options
1> turn off V-sync
2> turn refresh to 30FPS
3> 4-core processors struggle in this game as it is CPU processor dependent
4> turn on real time weather-traffic
5> use Bing as map program
6> lower global display level to medium to start with

I tried all these and got it up and running into training.

Ryzen 5 3600-----16GB DDRam-----Radeon 5700XT 8GB at stock speeds ASrock X570 Gaming 4 Mainboard.
hope this helps.

World map is working for you? Cause I havent any problems with training. For me just crashing when it’s loading before world map. In windows mode let me get to one picture of the land an crash or stay in there and nothing happens.

Hi All,

I am reading the posts in here and I hoping there is some sort of fix for this. But I cannot get past Cessna screen either. Crashes every time. I have not been able to play since I bought the game. This is the error I have seen in event viewer.