My game keeps crashing every time it loads

My system info.

Many have the same issue and no solution has been found yet.

Thank you…

Exactly the same as mine. I believe mine to be related to an issue with the graphics card not liking DirectX 11, but since so many people report a crash at this same moment, I can’t help but feel there’s more to it.

K0oLbReEzE - As a test, did you try disabling your Nvidia/Radeon display adaptor (via Windows Device Manager) card and running with the onboard Intel HD graphics card? That stopped it crashing at the Cessna screen (but the games then runs ver slowly).

I’ve noticed that the game crashes on startup if you’ve got an AMD Ryzen CPU and the windows power setting is set to “AMD Ryzen High Perfomance”. Set mine back to “High Performance” and i now no longer crash at startup.

Hope this helps at least some of you.

image

same here currently re installing the update bar says 16gib but its already downloaded 43gib did anyone have this problem ?

I had a similar issue where my Motherboard set my ram 2133mhz instead of 3200mhz and now it runs fine.
To check what speed it is currently go to the memory section under performance in task manager.
If you know that you bought a higher speed ram than what is shown look up how to change the xmp profile in your bios.
For some reason some default to the minimum of 2133mhz.

Got 3600Mhz RAM set to 3600Mhz

I know it works for you I meant for other people just if there’s wasn’t. I accidentally replied to your comment though.

1 Like

Hi, another user suggested that the CTD at the cessna loading screen (occurs if the Nvidia display adapter is on), maybe caused by your Microsoft Online account not recognising the Nvida under the graphics card details for the device you ar using (in the device tab). This is true for me (my microsoft online account just shows the Intel GPU). However, I have tried to update this in the MS account but am unable to do so. It would be good to test this theory - could people check their online accounts (and see if their correct graphics card is recognised by the online MS account)? If a Nvida card is not recognised in the MS online account for the device, but the game loads fine, then this will at least rule this theory out as a potential cause.

Cadet, I think you found the source !

That’s a pretty crazy theory, but in fact my Windows account is also showing my onboard card.

We are definitely close to finding a cause and it is so frustrating that we can even find what the problem is and not be able to fix it. Zandesk is gone! Have not had a response since friday. I suggest we go to discord to talk more about this.

I agree - we are close. I have sent my Msinfo32 file to Zendesk for review. Hopefully they will respond with an answer. I don’t think it is caused by a conflict between the Intel UHD and Nvidia. I think its a direct issue between the game and the Nvidia. Will update you if I hear back from Zendesk.

1 Like

Same here. Mine has been doing the exact same thing.

Bypassing the NVIDIA card worked for me too, so there is definately something wrong with the interface with the card.

Also just a thought. How many of you having this problem are on notebooks? I think thats the problem. The monitor isnt plugged directly into the card. It has to route through the motherboard first. I have yet to find a way to make it work. Time to upgrade. Im over it.

Hi, I am playing on a note book. However, when I unplug the monitor and try just to play just on the laptop screen, I still get the CTD at the Cessna loading screen (if the NVIDIA display adapter has not been disabled).

Same here Cadet. Its a shame. Because I can get to the runway with the Intel GPU but its so choppy you cant play. Currently researching parts to build a new one. I haven’t built a computer in 20 years, so much has changed.

u will propably need to wait some 4 days ( i am waiting since monday )