My MSFS has freaked out - Autopilot and yoke and instruments

Here’s a strange one for you all. I have been using MSFS with a Saitek yoke, throttles and rudder pedals. I also have a Logitech switch panel and multi-panel. I have had some periodic issues with the multi-panel, especially with the altitude almost always starting at, 99,999 feet.

However, today, I did a longish flight in a GPS equipped aircraft and noticed it would never successfully use the NAV…the HEADING and ALT and Vertical Speed were working fine. The NAV would never “take”. I finished the flight using HDG.

This evening, I started another flight. I noticed the multipanel was flashing some. After takeoff, the autopilot would repeatedly turn on by itself…then off…changing the VS from 700+, 1000+, 100-, 300- ,. All over the place. HDG and NAV lights would flash as well. SYstem would just fly in circles never finding the heading. You get the picture.

SO, I reboot the computer, reboot the yoke and panels, turn off all mods and addons, and restart MSFS. The same behavior. I DID notice, very strangely that as I was on the runway waiting to take off, my yoke suddenly showed as turned completely to the left even though it was physically straight. A few seconds later, it straightened itself out. Also seemed as if the left rudder pedal was fully pushed…then OK. So, I turn off the switch panel and multipanel and leave them off and re-start MSFS. Basically the same behavior. Except this time the yoke turned itself completely to the right for several seconds.

When flying, the gauges and what is happening are not in synch…showing a 1500 fpm climb on the VSI, even though I am descending…then the reverse.

I’m pretty well stumped. I was wondering if something has broken inside the yoke, and the autopilot was freaking out because it is reading a complete yoke turn and turning itself off…then trying to turn itself back on when the yoke “straightens out”. I THOUGHT it was a hardware problem until I saw the gauges and physical condition not in synch.

Anyone have any suggestions? Thanks

First step with that many accessories is disconnect all of them except keyboard and mouse, and unload any FSUIPC/SimConnect programs as well that facilitate comms between the PC and the controllers. If everything works as expected with just KB/M, then you have a suspect pool to start weeding out.

We ask that everyone please use the green Community Support subcategories instead of General Discussion for help. I have moved your topic.

I use a Saitek X52 Pro HOTAS and I have key reassignment problems. My Hotas has a Latched clutch function for for changing profiles in flight. I turned it off to make the Button 31 an active one and the pinky switch that was the brake now isnt detected.

Saitek equipment and logitech drivers isnt a good combination. I use the Saitek / MadCatz driver set in Windows 10 and all is well now, stable flight and everything responds as it should.

Please always name specifics. Which aircraft? Which GPS?

Check that the MSFS assistants are off.

Make sure everthing that is still connected or installed is up to date.

Thats usually down to the plane having a slightly different alt hold setting on its autopilot
like having to set alt then arm it which the logitech panel cant do . usually once its armed panel will show correct alt, what this means is you cant use the panel to set the alt but usually works for everything else. Planes i know this affects is BAe 146, concorde, Carenado PC12, Emb 110 and i think 787 and pmdg 737 to me its not a huge deal i set alt on the cockpit panel then use VS on the logitech panel ok

I initially experienced this in the Asobo Cessna 208, then I tried it in the Carenado Skymaster, then finally in the Asobo 172 G1000.

When I started my computer this morning, and all of my peripherals, the Logitech Flight Panel was dead. No lights before or after MSFS is running.

I restarted (cycled the USB port) for the panel and the lights came on, but randomly. (not like the test) Display showed HDG and degrees…then HDG lights went off, and just showed degrees. Then back and forth slowly . Same behavior when switchng to ALT or VS.

If I fly a plane without autopilot, the behavior is completely normal. If I unplug the panel, and fly a plane using autopilot, the behavior is normal. And the final clue. When I use the flaps up/down switch, it is glitching…sometimes working and sometimes not, seemingly at the same times the panel is glitching.

So, it is a problem with the panel.

I think the simplest solution might be the easiest. SO…here’s the embarrassing thing. I was using a USB to USB extender cable because my USB hub was JUST a little too far away. I unplugged the extender cable and plugged directly into the hub. All the problems went away. I suspect the extender cable or connection had gone bad.

I thank everyone for their input here, but hope this post might help someone else save a bit of time.


One of these things… lol… good you found it and thanks for letting us know! Happy landings!

Well it worked perfectly for almost a full day. Tonight, the multi panel lights up for 10 seconds and then dies. But now the switch panel is completely dead too…