(NDU registry change) Increase performances immediatly! AMAZING! Tested and aprouved!

Curious, if one is able to safely turn back this NDU change after making it? I see others have claimed the have switched it back but I also see the warning message at the top. Im not the most tech savvy so hopping others could clarify the ramifications here.

I can’t see why not. It’s just a service, albeit it a hidden one. Just change its startup type from disabled to automatic, then start the service manually, or reboot.

sc config ndu start=auto
sc start ndu

Or if you prefer:

Set-Service ndu -StartupType Automatic
Start-Service ndu
2 Likes

this “change” is nothing else as stopping the ndu service. BUT because these service is a kernel driver, it is not so easy as “stopping a normal service” and only possible over the registry and pc restart ( or just the commands @hobanagerik mentioned )… Here I mentioned the meaning of the “numbers” you change in the registry : (NDU registry change) Increase performances immediatly! AMAZING! Tested and aprouved! - #435 by MichaMMA

And realy… I not expect any kind of issue with disabling this. This driver only collects statistics.
Why some users see a positive effect of disabling this kernel drivers, is still unknown.

2 Likes

If I had to guess I’d wager this is due to a decreased presence of real-world Live Traffic on initial load-in. You’d need to control for that variable to A/B test this.

Snake oil in a packet.

1 Like

I tried it. It did nothing in my case. Then again. My provider just sent me a letter today in snail mail asking how i liked my free doubled internet speed? Lmao. Wish they told me as my router doesnt support it. Lol

1 Like

I don’t really know. It works fine for me. But maybe it is something only concerning certain PC-configs, just as random as the behavior of msfs

Dear all, i had exactly the same problems that my performance went bad after a specific time or what others were mentioned after long haul flights. I tried nearly everything, but right now its not occurring anymore.

History:

  • Tried the NDU fix, did not work, but its still active

Right now:

  • Switched off Photogrammetry
  • Switched off Rolling Cache in the Sim (Before switching off deleted it)
  • I have the google maps replacement addon with high LOD enabled and the Cache in the Mod set to 100 GB
  • Traffic in the SIM switched off due to just flying on vatsim

It seems one or more of those mentioned points solved it but not sure why or which one of these. i can maybe try to find out which one.

System is Ryzen 9 5900 x 64 GB Ram and 3090 graphics card.

Graphics settings just set to ultra with vsync on to 60 fps. Resolution is 3800 x 1600 and i have 60 fps with the pmdg 737 when flying and around 40 when at bigger airports with a lot of vatsim traffic, but its running smooth and no degradation.

Some people already mentioned also it can have something to do with the connection to Microsoft / Bing as some people also wrote about the dev on dev off solution.

I am happy that is gone

Did anyone tried removing the HDMI audio drivers? I don’t use them and was wondering if that would help?

Thanks

They certainly used to cause problems with other software in the past, so I removed them; and, after my last hardware upgrade and fresh install of Windows 10, I have always omitted them from the Nvidia driver packages through a clean install each time.

1 Like

Doesn’t work here.
Also turned off Photogammetry and deleted rolling cache.
Doing a 4.5+ hour flight and the frames just tank when I’m panning around the cockpit.
I’ll wait and see what happens with SU10.

Hello
You can try the following.
I am doing 6-7 hour flights and it seems to work.
Now I will see how it behaves with 12 hour flights

Points to highlight and for me the most important 4,5,6 and 7
(I hope it helps and everyone can enjoy)

Save as ‘Default NDU.Reg’:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Ndu]
“Start”=dword:00000002


Save as ‘Modified NDU.Reg’:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Ndu]
“Start”=dword:00000004


Just click which one you want to use! Just reboot afterwards!

:slight_smile:

3 Likes

I tried this NDU fix and it worked for me.
Performance is better, in outside view when i rotate the camera around the plane there are no more hitches, stops and stutters!
:+1:

Yeo, I’m normally sceptical of these sorts of ‘tweaks’, but the difference is night and day for me. Significantly less stuttering

The biggest difference I’ve found has been from creating a custom driver when NVIDIA updates. The driver they send out is filled with nonsense that slows your PC down in the sim. I’ve used the ‘skinny’ version for my last three driver updates, and my stutters and issues have been reduced to the days when MS/Asobo releases their updates and their servers are slammed. It’s around a 5-7 min process once you get it down.

  1. Download new/current driver from NVIDIA’s site for your specific GPU
  2. Wipe old driver
  3. Reboot in safe mode with all internet connections disabled(so your PC doesn’t update on its own)
  4. Unzip the driver you installed, open it, and select the parts of the driver that are needed. Disable the other nonsense using NV Clean Install
  5. Install driver
  6. Reboot, turn your connection back on, and enjoy.

I recommend taking a screenshot of your NVIDIA control panel settings. They will reset to the defaults on updates.

Here’s the latest one:

1 Like