New 11700k and Asus Z590 for VR. Flight sim crashes when I click on panel in cockpit

Reinstalled Flight sim and set mouse to default as advised.
If I click on altitude or heading etc, the sim totally crashes 8 out of 10 times.
If I don’t use the mouse at all, no crashes.
I’ve tried a different mouse, different USB ports, using windows drivers instead of Logitech.
I’ve just got my Rift S working ok after months of problems by installing a new PCI-e usb card and though this mouse problem was there before, it seems worse now.
I’m currently reinstalling again just to be certain Msfs has all the right files.
Any ideas or things to try?

Asus Tuf Z590 gaming-plus
11700k
Rtx 3080
32 3200 ram.
Noctua D15
Oculus Rift S.

ASUS Has acknowledged a problem with some of their motherboards having a capacistor installed backward, up to and leading to a fire. GO TO ASUS site and see if your motherboard is affected, they are replacing them. You will need to file a claim. If not affected, you can try couple of things.

  1. Do complete and full virus scan.
  2. At ADMIN command Prompt, run “sfc_/scannow” and when finished "Chkdsk_/F/R. That one may need system restart.
  3. Delete all USB ports and devices under device manager and restart PC. See if it works then.
    NOTE: if you have some aftermarket throttle devices, they take over Mouse functions for certain buttons/switches. Make sure that is not a problem.
    My gut tells me your VR stuff is causing this. Try removing that and see if problem goes away.

Does the game crash regardless of whether you’re in VR or not when using the mouse?

I also run VR, incidentally the only CTD’s I’ve experienced was when I had HAGS enabled in conjunction with Nvidia driver 497.09. As soon as I disabled HAGS on my PC, everything was peachy. I noticed no change in performance with it switched off, even on other drivers.
I still use 497.09 because it’s giving me good performance in VR on my PC.

All of that aside, your issue does sound like an interesting one, hopefully, we can help you get to the bottom of it.

Will check today to see if it is the same in 2d…
……it was only in VR and Hags was off.
It was caused by corrupt windows files.
Now all ok.
Many thanks.:ok_hand:

Scannow cured it for me. Cheers…
There where corrupt files.
I had installed Windows 10 on my new motherboard by using recovery and wipe all files on drive.
Maybe it’s better to install from scratch next time.
It only happened in VR.

Thanks for that. It was driving me mad.:+1:

1 Like