New G2 and 10 Hours Later Still Can't Get It to Work

Well, this entire thing has been a freaking nightmare. From the idiot in the packaging department at HP that thought it was a good idea to put adhesive backed cellophane on the controller buttons that took 40 minutes to get off, to finally getting into MSFS some 9 hours later only to find when I launch VR mode, it launches VR mode on my desktop and the headset stays black. I don’t get it.

I’ve got OpenXR installed, Windows Mixed Reality for Windows 10 installed and the damned headset works in the Mixed Reality Home,. just not in MSFS 2020. Anyone have any ideas? This is so super frustrating.

CTRL + TAB for mod VR

Are you ctrl tabbing to activate VR mode once in MSFS?

If you have any custom binds saved there is a bug in msfs that means the standard binds for VR mode may not be set. If so you’ll need to set your own options for enter/exit Vr, recenter view and menu.

Edit - sorry just re-reading and are you saying that you get the VR view on your desktop? Does it move with the headset?

Do you have steam? You could try activating the steam OpenXR runtime as default and see if anything changes.

Have you tried any other games? MSFS is the only one that will be running OpenXR so at least if other games are working you’ll know the problem lies specifically with OpenXR which will be helpful.

Thanks for the reply. I got it to work by rebooting my PC. It still does this if i run a VR session and then let the headset power off after use. If I try to launch WMR again, the headset staysd black. Might be a driver issue with my GFX card as I am using a RTX 2080ti with a USB C port. Dunno, still trying to nail it down.

Sounds like perhaps the system is sleeping the USB port and messing with your chi.

Maybe try checking windows power plan settings - usb selective suspend - disable.

When the headset goes into standby mode you should get a ‘wakeup’ headset option in the WMR window.

I’m also using RTX2080ti with USB c port and have no issues

Thanks guys. Yes Before I even connected the USB I made sure the USB ports weren’t hibernating in the power plan. I get the “Wake Up Headset” option in WMR, but it never wakes up. However, it is tracking in WMR. Weird as all get out. The only thing that fixes it is if I disconnect the power brick before starting WMR, and then it’ll work.

To be honest whenever i’ve finished in VR I always switch the power off to the headset, I see no reason it leaving it on really, even if i’m going to be back in VR a few hours later.

I’ve got mine plugged into a battery backup that runs my PC as well. So flipping a switch there isn’t an option at this point. Would hate to have to install a power strip because HP cheaped out and didn’t put a power strip on the headset itself.

I had zero luck using the USB-C port on the 2080Ti I used to have in my rig. In fact I can’t get my G2 to work on ANY of the USB-C ports on my PC. I have to use the USB-C to USB-A adapter that came with the G2.

Seems the G2 is very picky about its USB port. I’d try using another port or using the adapter.

Yeah, that is what I am thinking. How HP could go to revenue on a product knowing it doesn’t always work with current USB C ports on leading GPUs baffles the mind.

How do you switch off power to the headset?

I just turn it off at the wall mains socket (after closing the mixed reality portal first)

Hey folks, Yet Another Stuck in the Cliff House post

This is after the latest MSFS update. clt + tab no longer works. Changed to another mapping even tried it on a button on the joystick, no luck, updated to Windows 20h2 no luck. tried changing to steam openxr but I can’t use the mouse in there so not sure as yet, back to WMR openxr and no luck.

RTX 3090

HP G2 with no controllers.

Help!

Not that is any excuse for HP but it is worth remembering that USB C does not define much more than the shape of the connector. You need to check the functionality of the USB C ports on your specific device to know what they actually do.

USB C ports will commonly support some but not all of the following functionality:

  • Thunderbolt 3 support for 40Gbs
  • USB 3.2 Gen 2x2 for 20GBps though most are only USB 3.2 Gen 1x2 at 10GBps but the occasional older USB C may only support 5 GBps.
  • Display Port over USB for video connectivity
  • Charging port for the host device
  • provide charging for remote devices

TLDR version not all USB C ports are the same - caveat emptor

2 Likes
This is after the latest MSFS update. clt + tab no longer works

Yeah, same here. After World Update 3 I can no longer get into VR with ctrl-TAB or button in main menu. Reverb G2 also. Was working before update.

Update: After giving up on re-enabling VR, I found I had to mess around for a long while to get non-VR flight working properly again (was very slow and then MSFS window was opening off-screen somewhere and with full screen I was locked into a single low res mode. Several reboots later, some messing with Windows display options (extend vs disable internal screen), disconnect/reconnect external monitor, etc, something finally fixed it. I got my full list of available resolutions back again for full screen and the VR option started working again. Sorry I can’t be more helpful - I don’t know what was screwed up and what finally fixed it.

Unfortunately, my eventual VR flight was brief (10 minutes or so) and it ended abruptly with a sadly too-familiar lockup and eventual crash-to-desktop. Time for sleep now.

Yep, mine is working fine on an X570 board from a USB3 rev. 1 port (blue), wont work on the red rev. 2 ports or the USB C port which is also rev. 2.

Does work from a rev. 1 hub connected to a rev. 2 port though.

Thanks Major, still stuck here, DCS works with no issues, I have MSFS in Steam, was that yours as well? I have two graphics card and tried disabling on of the screens, messing around with which was the primary and still no luck. Seems like we are not the only ones with this issue after this update…

Yeah, my MSFS is also via Steam. My configuration is that I’m running on a MacBook Pro with an external GPU box (Razer Core X and 6800 XT card). Normally my laptop is closed and the built-in screen disabled but something funky was happening with the display handling after the MSFS update and some Windows 10 updates (one of which still doesn’t complete successfully).

Also running an egpu here as well lenovo x1e via an r43sg pcie to M2 NVME adapter. Might try disabling the internal graphics and screen.