New Helipads with Cold and Dark starts

The new helipad creation is great but I wish there was a way that your helicopter could be started in a cold and dark state rather than always ready to fly.

Does anyone know if there is any discussion on this matter?

Maybe you want to bump this question up

1 Like

Helipads in the SDK are a mess at the moment.

You can join devsupport as well, and report your issues and request/ideas so the Dev team can work on it :relaxed:. Messages there have a lot more attention than this forum

I have an operational Sea Plane Base, water runway and dock working fine. I’m wanting to add a land-based helipad. I’m using the new Helipad object, and it goes in fine, I can add a “start” and I can set the direction of the take-off". It all seems to be working. When I go to the SPB in the sim and select the start, I see my runway, my dock and a new “Helipads” with “H01”. I select that. Every time, it starts out on the water runway, NOT on the helipad. Any suggestions?

Are you using one of the msfs helicopters or a third party one? Third party helis currently have a wierd issue where they dont snap to the pad correct unless you modify the .cgf file.

Using the Cabri and Robinson. I think they are Asobo. I built a scenery set with a water airport (SPB) and a land-based airport about two miles apart. That set works fine. I then go to a group of SPBs I have built and put the helipad object in. It worked fine the first time I used it. Then I put a second one in and my old problem returned. The FLY NOW will not light up trying to take off with the Cabri in the helipad. If I try with the Robinson (water capable), it starts out on the water runway. So I cannot get it to work with multiple SPBs. I’m wondering if the “select parent” in the helipad properties is part of this?

Yeah the does sound right.
You could always just add another bgl to the project and create the helipad in that with icaoh or something
At least that way they would package and appear together.

OK, I’ve taken two of the dock locations, TF01 and TF01. I took the airport out of TF01 and redid it putting in the Helipad. It works! So I did the same thing to TF02, it doesn’t work at all. And I created them the same way. I’m thinking it has to be the helipad has to be somehow LINKED to a specific airport, and it should do that within the bgl, but it doesn’t seem to work that way.

Here’s a Wishlist topic you might want to look into:

It is not specific to the SDK but about the ability to spawn anywhere.

That would solve the problem! On our WayPoints page, if you do a CTRL-F, and put in “Heli” you get all of our 98 helipads highlighted, the lat/long is ready there to copy. It would be great to paste that and be ON THE GROUND … that would solve the problem. I notice the Airbus Heli doesn’t like to land at the “Helipad” object … the Cabri does ok. I just think there are several things about the helicopters and helipads that Asobo has yet to work out. We’ll be staying with Gate H at RTMM until it is sorted.

At RTMM, the latest download (Express all in one) has helipad parking modified so the new FLOW (Parallel 42) mod can place you on the helipads. (You must always start a non-marine heli at a ground base (Like Misty’s Place), then you can use FLOW. The sim won’t let you put a non-marine vehicle at an airport that has water runways only. It doesn’t yet recognize the helipad is “ground”. So start on a ground runway, then use FLOW to position yourself on the pads.

If I may add here,

I just started again with the SDK. The last time I even set dev mode was at least a year ago. Anyways, I’ve gotten past the ridiculous “screen resolution test” (bug) in the menus and I have built a nice private helipad way up in the mountains somewhere. Ah, nice.

The one thing I can’t figure out is how to start my heli on my pad as though I just got in or, as they say, cold and dark. Is it possible?

I love helicopters!
Happy flying!

Currently if you want to create a cold dark start helipad you will need to place a parking spot under the helipad. I believe if you use the ‘ga_parking_small’ it will not generate any services but i could be mistaken.

Thanks for your input. I tried that. Didn’t work for me. Or maybe it did but I couldn’t figure it out.

The dev mode is a nerd’s paradise with an almost intentionally horrible user interface. The interface is so clumsy, so repulsive that I have decided to waste no more time on it. Too bad, it could’ve been fun.