New Nvidia 497.09 Always CTD

Done. Fixed. and… THANK YOU!

Thankful for all the experts here that make life wonderful!

1 Like

You can also roll back a driver using Windows Device Manager. Right click on your video card, properties, select the Driver’s tab, then Rollback Driver. Tell MS why you’re rolling back and click OK (I think) - it’ll take a few minutes then you’ll be back to your previous driver.
I just did this myself. I didn’t actually have any issues with the newest driver, until I started using the Beta hotfix which says it fixes the latest driver crashes, among the other things, then CTD galore along with some blue squares. Rolled back and now everything seems fine.

I think a clean install will render device manager rollback as “greyed out”. In other words, can’t rollback. Glad some are getting in the air again.

1 Like

Try going there, make selection and on the bottom list it give us previous available drivers

It’s easiest to just select the Studio Driver which will always be the most up to date with the fewest issues.

I posted this about my findings with settings - Surprisingly good results using GSYNC and VSYNC

There is not a chance I am installing 497.09 again, it only works for some people and I’m not one of them.

However I’m on the latest W11 preview and in the beta test I am getting fantastic perfomance from the 496.74 … you are all in for a real treat
:star_struck:

I downloaded the new driver two days ago and can’t even start a flight without CTD. However, deleting the working title GS3000 mod from my community folder stopped the CTD’s. Then I had random blue squares in the scenery, but at least the other cj4 mod worked. I always fly VR. Someone posted the driver has been fixed and to download from NVDIA and re-install. I will try that tonight. Otherwise I am rolling back

nVidia would most likely release as a new driver version not re-release a fixed old version.

3 Likes

Same here with this driver.
DX11, GTX1080

This would explain my issues last night…5 CTD and I gave up. Saw the blue patches in the final one. I’ll check the driver version but I’m sure it will tally

Disable HAGS and running public beta 1.21.18.0 DX11 works on my system.
Extra gain between 5-10 fps depending on the plane and the chosen scenery.

1 Like

Seems so obvious but I’ve had it turned off since forever.

Edit: they must be working on it, it would be nice if HAGS could do something positive

placeholder - poke with stick/do something meme

I’m not sure if I turned HAG off before or after the driver release and now curiosity is getting the better of me. Fool that I am I shall give 497.09 another try
:grimacing:

1 Like

Please report back. I have always had HAGS turned off since day one, so I will give the new driver a go with DX11 when I get home tonight.

It is being reported on the Avsim forums that there are no driver related CTD’s or blue / purple patches on the landscape with HAGS turned OFF.

Some people probably don’t know if it is on or off, accounting for the inconsistency we are seeing in the bug - i.e. why some people have the issue, and some don’t.

Can confirm having done a quick transfer from KLAX to Santa Monica in the Caravan (can confirm new Garmin setup too, very nice :smiley:) and I did two short discovery flights including Singapore which was an instant CTD before with HAGs on obviously … Performance is similar to 496.74 I’d say.

1 Like

Thanks for the feedback. I will try them as well when I get home tonight - making sure HAGS is off! :slight_smile:

Just gave the 497.09 driver another go with Hags off and haven’t had a CTD yet or any blue patches.
With Hags on I would get a guaranteed crash when loading into a 2nd flight.

HAGS has always been on since updating to Windows 11 on my end and still CTD. I haven’t try to undo it since installing 497.09 but this setting never was touched.

I think the key is turning it off.