New Nvidia Drivers: GeForce 496.49 WHQL 26/10/2021

OK then. I will roll back to that driver. Thank you.

1 Like

I just got the best performance from MSFS 2020 on my i5 10400 and RTX 3070 with this new Nvidia Driver 472.12 DCH and two driver settings changes. I did an express installation and had no issues with the driver update.

Yesterday when I ran MSFS 2020 in developer settings I could see I it was CPU thread limited but today someone in this thread suggested going into Nvidia Control Panel program settings for MSFS 2020 and changing the following two settings which I did after updating the driver.

• Threaded optimisation was set to auto but I changed this to ON as recommended
• Low latency mode was off, I set this to ULTRA as recommended

Those were the only changes and the driver update.

Yesterday over JFK in a 747 my fps would drop to the low 20s but actually the stuttering would make it feel even worse like the 10s. I knew something was different as taking off the runway in a 747 from Newark Intl. the fps stayed in the high 30s-40 normally low 20s. Away from the airports fps would climb to 40. I have max frame rate set to 40. Flying low over La Guardia my fps stayed at a steady 40fps. I buzzed the JFK tower with my 747 and the frame rate at it’s worst only briefly dropped to 30 but was mostly in the mid 30s. Landing at JFK my fps only dropped at most to 35. My GPU utilisation was around 50-60% for the most part. This is with cockpit and external views.

All at 1440p HDR on Windows 11 with high settings 100% render scaling 100 LOD, all data on, photogrammetry, live weather, multiplayer, all airport traffic set to 100 etc. I use AiTrack + OpenTrack to provide TrackIR so this isn’t some easy to render static view, there’s a lot of camera movement happening.

I thought it would take a 12th Gen Intel CPU or later to fix the big frame drops at busy airports, turns out a driver and driver settings can have a massive impact.

I recommend these changes too.

https://flightsimulator.zendesk.com/hc/en-us/articles/360016142680-All-versions-How-to-improve-the-performance

DISABLE CPU & GPU OVERCLOCKING (ALL VERSIONS)
We advise against using overclocked systems to play Microsoft Flight Simulator. The increased voltage causes overheating and can gradually damage your computer’s hardware (CPU, GPU, RAM, and motherboard).
If your system is overclocked:
1. Disable Intel Speedstep on your Bios overclock menu
2. Lower or disable your CPU overclock values
3. Disable GPU overlocking for your Microsoft Flight Simulator game profile on Radeon Software or Nvidia nTune (this applies to custom user overlock settings, not for factory overclock settings of the manufacturer)

DISABLE FULL-SCREEN OPTIMIZATIONS
Having your monitor’s DPI set to a value other than 100% can cause issues with Microsoft Flight Simulator. As such, we would recommend disabling display scaling on high DPI settings for Microsoft Flight Simulator.
To do this, follow the steps below:
1. Find FlightSimulator.exe.
2. Right-click on FlightSimulator.exe and select “Properties” from the pop-up menu.
3. Select the Compatibility tab.
4. Select Change high DPI settings and then select the Override high DPI scaling behavior. Scaling performed by: Application check box.

USE GAME MODE
When you’re playing games on Windows 10, Game Mode makes gaming your PC’s top priority, so you get the best possible game performance. For more info, see Use Game Mode while gaming on your Windows 10 device.

3 Likes

I’ve posted something about this yesterday!

1 Like

Because this topic is using the ‘VR’ tag I just want to add: I didn’t revisit this with the 472.12 though, but in all previous driver versions I’ve tried and all previous FS2020 version I’ve also tried in VR, Threaded Optimisation has always been better OFF for me (SteamVR/Index AND WMR/G2).

2 Likes

Hi Capt’

I installed the new 472.12 driver using your recommended method for completing a skinny install for the driver. All went well however, I had to re-start my computer once more to get the Nvidia CTL panel to show up and initialise. I had to use DDU for the uninstall of the previous driver because the uninstaller was missing from the list of programmes in the Windows Uninstaller.

With my new B550 MB, AMD 5600X, GTX 1070, 16GB RAM and graphics settings, (1080P) on full-ULTRA scattered Cu cloud and flying from Orbx Southampton Airport in the CJ4, (with mod) and frame rate limited to 30, I am getting a steady 40FPS! I have no idea why I am getting 40FPS when I have set 30 FPS in the Sim? This is with high traffic settings too. I have now enabled Game Mode too. I did not have the slightest hint of a stutter which is quite amazing!

Charles.

2 Likes

Showing my ignorance here but I am still back on 471.68. With an RTX 3090 now after SU6 and hot fix 1.19.9.0, my one remaining immersion-spoiling issue is pop-ups. Everything looks great in 2D and VR in ULTRA or close-to-ULTRA in both and I have set my FPS limit to 30 in the Nvidia Cpl for MSFS and do get 30 fps in the sim (otherwise the GPU would be hard at work cranking out a much higher fps). But whether flying over Mr. Rainier in an Icon A5 in 2D or VR, although they are not major, there are these constant little burps of scenery here and there especially when viewing the flight from the external camera behind the plane. I have Offscreen Terrain Precaching set at ULTRA, which according to Jummivana has the following effect:

  • Ultra - This is will have no offscreen caching at all, and everything will be maxed out based on your graphics setting. The quality in front of the user is the same as from behind the user, so nothing needs to be loaded. This could come with some FPS drops when turning the head, but would result in higher FPS and lower memory usage when looking forward and not turning your head quickly.

Source: [RELEASE] Release Notes (1.19.8.0) World Update VI: Germany, Austria, Switzerland Now Available! - #2 by Jummivana

Sorry if this question is in the wrong place but basically I’m interested to know if I go for 472.12, whether that’s likely to have any significant impact on the pop-up problem. Otherwise the sim visually and performance wise is pretty incredible for me now, especially in 2D. Someone else’s post suggested that a difference in the relative position of the external camera vs. the plane was the cause of the pop-ups (nothing to do with the Nvidia driver) but some of the pop-ups are right on Rainier’s peak as the plane passes over it with the camera close-behind. Since the scenery at the location of the pop-up looks great before and after the pop-up insertion, it seems to be a matter of timing and the GPU or MSFS deciding to insert a bit of scenery way too late in sequence.

1 Like

No. It won’t. Besides just trying it is quicker than waiting for people to answer here :wink:

2 Likes

Because ingame vsync is dedicated to 60Hz monitors and 60Hz TV.

In game turn off vsync apply and save > quit to desktop.

Launch nvidia control panel

1 Like

Hi, what should be the NCP setting for Vsync in this case ? Thank you !

vertical sync - off
or
use the 3d aplication settings

Many thanks.

I have been following this approach (Vsync / limiter in game disabled, limit FPS in NCP and Vsync in NCP to off as you suggested) but I am experiencing screen tearing when panning inside the cockpit .

I am using a 144Hz 2560x1440 monitor for the game and have another 60Hz 1366x768 monitor for out-of-game charts etc.

I have followed the two approaches below, each with its problems:

  1. I limit FPS in NCP, set Vsync in NCP to off, keep frequency of the monitor at 144Hz:

my GPU and VRAM usage remain low - around 60% (I am OK with 24 or 30 FPS) but I get the screen tearing.

  1. Use the in-game Vsync and limit to 20 or 30 FPS and set frequency of the monitor to 60Hz:

the GPU usage increases significantly to 90-100 % but then there is no screen tearing when panning.

GPU is RTX 2060, CPU is i7-9700 - running mostly ion High expect clouds and off screen caching (ultra) and terrain LOD 150.

Is there something to do to get the best of both ? ie lower usage and no tearing ? Apologies for the length, it is just that I am getting frustrated again :slight_smile:

What about monitor?

The main monitor is 2560x1440 144Hz and the one I use for charts etc. is a very old 1366 x 768 60Hz. In an old post I had read that if I were to limit FPS in game, I should set the frequency of the main monitor to a multiple of the FPS I set - so for example, if I set 30 FPS I shoudl set it at 60Hz, or 120Hz, the 144Hz would not make sense. Thats what I did in approach 2. In approach 1, (NCP FPS limit) I left it at 144Hz.

Read private message.

ah note:
you not set FPS in-game, instead you set Vsync Steps :slight_smile: A one-to-one FPS mapping of these values you see in-game-setting is only possible for 60fps monitors. In contrast you limit in NCP the amount of fps. ( eg. also and how to compute the steps : 144 | 72 | 48 | 36 )

reverted back to previous driver and turned photogrammetry off and now the sim runs fine on high settings and some ultra. system is i7 32 gig mem and rtx2060. The 472.12 nvidia driver was causing shimmering and low fps on my system

472.12: apparently the best driver for VR in MSFS 2020!

With that setting, what should “VR pre-rendered frames” be set to?

Just out of curiosity, I went and found a copy of nTune online and installed it. Bad idea! It seems whatever it is and whatever it does, it’s straight out of 2007 (literally), so it doesn’t work for today’s GPUs. Some of the subcomponents would BSOD as soon as I tried to run them, and the nTune app itself just never started.

Unless it turns out there is actually a modern 2021 version of it and I just happened to download the wrong version by pure bad luck anyway. Otherwise just say no!

2 Likes

I think Ultra setting for the Low Latency choice in NVCP then forces the CPU Pre-Rendered Frames to 1 regardless of what you choose for that setting. I think this might be alluded to in the NVCP when you hover over the setting and it has a description of that setting and its choices. I might be mis-remembering this but others can weigh in here too.

Hey @KevyKevTPA , I don’t use a VR headset so it’s not relevant for me so I leave that at its default 1.

Yep nTune that’s the old way of overclocking old Nvidia GPUs didn’t expect you’d jump into the DeLorean :joy: . It’s now built-in to the driver, alt-z then performance>performance tuning but try to keep it turned off though.

If your PC is struggling over airports due to CPU thread reducing LOD level of terrain details and object details to 50 can really help whilst keeping the other settings on high/ultra.

Of course with so many variables what works for one machine won’t work for every one.