New problem with Bravo and TBM... new to me

I tried to find another thread relating to this issue and did not see anything.
This issue showed up literally overnight after my first two days with the alpha, bravo, and TBM 930 being successful. I’m completely baffled. Below is a copy of what I sent to Honeycomb help desk.

Read carefully.
I received the alpha and bravo a few days ago and quickly found a youtube video someone had posted with a method of doing the unique engine-start of a TBM 930 in MSFS. The method worked beautifully and I was up in the air in a short while. While in flight… after a few minutes, the engine would begin to shut down. With the “in-sim” throttle still in it’s normal running position. No other switches were being flipped or activated in any way. I was able to negate this problem by switching the TBM ignition to “on” instead of it’s usual “auto” position. This gave me an “ignition” warning light on the tbm as the ignition system does not need to be activated during flight. But ignoring that was easy and at least the engine was not shutting down anymore. Everything was fine after that. Flew successfully for 2 days.
Woke up this morning and have a new problem literally out of no where. The alpha and bravo remained mounted on my desk overnight and literally nothing was moved in between. Upon starting the tbm engine and adding fuel at “low idle”, the engine startup sound has a very distinct hesitation sound… almost as if the throttle is being moved back and fourth from fuel cutt-off to low idle. But it’s not. The “in-sim throttle” is clearly in the correct position and is not moving at all. If I click and hold my right mouse button… which is bound to enable “freelook” in the sim… the engine continues starting up as normal until I release the right mouse button. You might think that means it’s an MSFS problem but it’s not. After extensive testing and troubleshooting I have determined that only temporarily fixes the issue because when that free-look hold is activated, the sim ignores input from any controls like the honeycomb or other brands. This can be confirmed by simply unplugging the Bravo usb during the attempt at engine start and of course… it immediately stops hesitating and continues spooling up as normal, just as it does when I hold the right mouse button down. Until I plug the Bravo usb back in, then the problem comes back. Additionally, if I plug my thrustmaster stick and hotas back in and do a-startup the old way… no issue.
I thought maybe there was an issue with the particular bravo lever that I was using for this keybind that allows you to move the throttle from fuel cut-off to low idle. That keybind is “increase throttle”. It’s important to keep in mind this is not the same as the throttle keybind that is used on a different lever for the regular increase/decrease throttle. It’s not even a keybind that is designed for an axis-based lever… but it works because the lever “notch” at bottom of travel has a separate “button” function… I think it’s "button 20-something… can’t remember off top of my head. Furthermore… considering “increase fuel” is not designed as an axis function… I tried binding it to one of the toggle switches on the bravo. Same issue. And of course… This wasn’t happening during startup yesterday or the day before.
Thoughts? Questions?

Don’t want to speak too soon… but I believe I finally fixed it. Still makes no sense why it changed overnight but both the start-up issue and the in-flight shutdown seem to be gone at this point and it’s after I found something that I thought I previously eliminated that the original youtuber posting the how-to video had pointed out. (not the video I linked in this thread).

Anyone want a link to the how-to? let me know.

I would like that