New project - ground elevation incorrect, object stuck in ground

Running Beta AAU1.

Just started some scenery tutorials, and found that when I load my home airport, the elevation isn’t reading correctly, and runways/apron only appear in a few places, but mostly I see default satellite imagery. Additionally, if I add an aircraft, as you can see, it’s below the apron.

Restarted a few times, been trying to figure this out for a couple of hours now… no idea.

Also just notice that objects aren’t appearing correctly in the Objects window - here, I have “ControlTower” selected, but it’s showing aircraft. Many Object types are simply empty.


When starting a flight at the airport, even though I haven’t compiled this or added anything to my Community folder, the airport appears incorrectly, as it does in the editor:

until restarting the sim.

FWIW, I followed a tutorial to add some objects to another local airport this morning, and it worked with no issues.

Any help appreciated!

You may want to bring this up at the SDK forum: All Posts - MSFS DevSupport

1 Like

Thanks - thought that’s where I was?

Is it a different forum? Apparently, it doesn’t think I’m logged in.

Because it’s a completely different website.

1 Like

You probably meant All Posts - MSFS DevSupport?

If there is a Photogrammetry layer involved, it might be a bit more complicated. Not sure there is though. You might need to exclude PG as well, but I haven’t worked with that yet.



If anyone here is already a member, can someone please send me an invite?

The site is a forum, not a discord, and shouldn’t need an invite.
Let us know if you have issues getting into that forum though.

Here’s what I’m getting when I follow the link. Since apparently, I can already post here


The initial link I posted wasn’t correct, sorry, use the one Pieter2427 supplied:

Thanks - yes, posted there. Not much going on yet.

1 Like