New Reverb G2 sound issues

I apologize if this has already been addressed, but I searched and couldn’t find an answer here…

I recently installed the reverb g2 vr headset and it appears to work pretty well visually with my setup. I previously was using a headset with mic to listen to only ATC while engine noise and other sounds were heard through separate speakers. Since the g2 has speakers and a mic, I was hoping to just simply replace the old mic setup and use the vr headset going forward. Unfortunately I have been unable to get the g2 to only play ATC sounds. I’m doing something wrong. In the sound options screen, I have it set to communication, and I am pretty sure I have my pc sound settings set the same as they were with the old mic. If anyone has had this problem, or if I am missing something please advise.

When started WMR go to the speaker icon and select as principal your speakers, not the USB 2.0 G2 speakers, I have to do always this, hope there were a way that WMR does not change the sound settings and only switch on the G2 speakers.

1 Like