New settings in WMR

Just noticed a couple of settings I haven’t seen before on the WMR settings screen under the Headset section as seen below.

Good thing we now have a slider to adjust the sleep timeout instead of having to mess around in the Registry. As for the other Enable/Disable switch whether WMR and it’s apps should be suspended when the headset goes to sleep, I assume it would be a good idea to move that one from its default setting being enabled to disabled. To avoid potential issues with MSFS including CTDs when the headset suddenly goes to sleep.

Anyone else already played around with these new settings?

I’m using an HP Reverb G2 and my GPU is a 3090 if of relevance.


Finally the sleep timer is in, took them long enough! Especially handy for benchmarking

The sleep timer has been an option for a while now as it is one of the first settings I had to disable when I first got my G2 about 2 months ago. Same with the input switching setting. You guys may only be seeing this for the first time, but I assure you they have been there in previous versions.


hi, how did you managed to see the sleep timeout? i just checked mine but this section is not there…

this is how it looks for me:

It came for me with the latest WMR update a while ago, not the develloper tool. Also check your windows version.


1 Like

Yep, I guess it came with some recent update. Haven’t been in there for a while and found it by chance.

I like having the suspend option disabled since that will turn off the displays but still not make the headset go to sleep. Problem though is how the mouse have a tendency to disappear when you wear the headset again. Only way I’ve found to make it return is to switch to 2D and then back to VR. Which I try to avoid since switching from VR to 2D every now and then causes a CTD…

1 Like

I have input switching to set manual and no longer have this issue.

1 Like

That’s great info, will give it a try.

Tried this now but didn’t fix the issue over here unfortunately.

Sorry that didn’t work for you. Just to be clear, I have Sleep Timeout set to Never and Suspend WMR set to off as well as Input Switching to Manual. With these settings, the head set should never go to sleep, WMR should never suspend and WMR should stay focused on FS2020 when it is the active window.

Thanks buddy but that was exactly what I tried. In my case though, the displays in the HP G2 would still shut off and when wearing the headset again and waking up the displays with WIN + Y, the mouse cursor is gone.

Fact is, setting the suspend option to disabled should make the displays go off. Since what that effectively does is to add the below to the registry, ie to activate a VR screensaver.


No big deal though, I’ve gotten used to increasing the sleep timeout to avoid having the headset go to sleep on longer flights. Then I make sure to wear/use the headset every now and then to avoid any potential burn-in issues. Also, I’m not sure how likely it is getting burn-in issues in the HP G2 since it’s using LCD displays. My understanding is burn-in mainly is an issue when using OLED displays.

That’s really weird for you, but at least you have a workaround. Re burn-in potential, the G2 is an LCD display so burn-in is not a factor at all. My previous VR headset, the PSVR, was an OLED display, but it obediently turned off when you took it off your head and, more importantly, woke up properly when you put it back on your head. When I tried the sleep function with the G2, it never woke up properly or sometimes not at all, so I disabled sleep and suspend straight away.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.