New to VR: Oculus Quest 2 Assistance

Hi All - I am really struggling to the Oculus Quest 2 VR headset up and running. I am new-ish to any type of gaming outside of consoles. Still not something I do frequently so forgive any ignorance, but I am quite enjoying the possibilities with MSFS20 so have been upgrading here and there to elevate my experience.

I recently moved over from the Xbox to a new gaming laptop. I didn’t go super over the top but found something that I thought would be enough to have an okay experience. Basically, I am having issues getting the Quest 2 to work properly. I can get everything loaded up and enter VR when I am cold and dark but everything is so jittery, half of it is black and I perpetually have a loading hourglass. The sim works flawlessly when not in VR so I must be doing something wrong, or maybe my equipment just won’t work.

I spent hours reading all of the forums and taking advice, but with it all over the place it is hard to piece together what exactly it is that I need to do. I opted for a new thread instead of an existing because a lot of the initials posts and responses are from 8+ months ago. Even the ones in the last couple of months seemed outdated to me with all of the recent updates. I am hoping someone might have had a similar or experience or can take the time to provide some instructions. I am mainly a Mac user so some of the super techy things stump me, but I can Google for the most part.

My PC Specs are as follows. I also have the Microsoft Store version of MSFS 20

Machine: Lenovo Legion 5 15ACH6, Type 82JW
Processor: AMD Ryzen 7 5800H 3.2 GHz
Memory: 2 x 16 GB DDR-3200 sticks, by G. Skill Ripjaws (upgraded myself)
OS: Windows 11 64 bit. It came with 11.
SSD: 512 GB
Ports: I have 2 USB type C ports. When I use the Oculus Link cable, it says the speed is 2.6 Gbps
Graphics: Integrated Radeon or Nvidia GeForce RTX 3050 Ti 4GB
Monitor: Native 155.6 FHD 165 Hz

Internet speed varies. At home I have about 800 Gbps steady when I am on ethernet. Wireless is about 100. 2.4/5G variable through Google WiFi mesh network. Open to other options too.

I have been playing around with the various settings but no idea if I have made things worse or not. I have tried the Oculus debugger and the Nvidia settings as well. Right now I think I have everything set to only use the GeForce GPU, performance mode is on, Thermal Mode is in balance, overdrive on. Again, when running without VR it is smooth as butter on high settings across the board. Almost never have CTD or black avionics issues, etc. and frequently do flights 10+ hours without problems.

I really do appreciate the collaboration of these forums and the patience to new simmers :slight_smile:

Thanks!

Unless it has changed recently, everything I’ve read has said that the Oculus app is not yet fully compatible with Windows 11.

This is true, Oculus app not currently supporting Win11, V35 current version. I’m stuck using AirLink which works -ish, but would prefer to use LINK over airlink…

Oof. I was afraid that was going to be the case. I heard the same thing as well and had hoped it was outdated info LOL. Any thoughts on virtual desktop or should I just cut my losses and install Win 10 and be done with it?

I’m using link (not airlink) on Win 11 no problem. That said, it performs like absolute garbage. I’m guessing that’s the same issue you’re having. I think part of it has to do with the Quest’s refresh rate but I am far too green to VR to know how to fix it.

I also have a new Oculus Quest 2 that I just setup with my Windows 11 gaming machine. It does work, but what a pain to get there. Here is what I have learned:

Don’t use the latest nvidia driver. There is a bug. There are other threads with the recommended driver.

Set the flight sim to use Directx11Reboot your oculus. Reboot your PC.

Do not use a wireless oculus link connection. You will need a wired Oculus link cable. Then use the Oculus app on your PC to test the cable and make sure you are getting a good USB3 speed.

It would be best to use a wired internet connection to your laptop.

When connecting the Oculus link cable, be sure to select “no” when the oculus pop up asks about allowing file access. Select “yes” to allowing oculus link.

In your FS settings, switch to VR mode and then reset all graphics to default.

If you are getting the spinning hour glass with the tearing screen, switch out of VR mode in MSFS (CTL+TAB). Unplug the Oculus link cable. Power off and on the Oculus. Plug in the cable, click “no” in oculus for accessing data. Click “yes” in oculus to use Link. Then go back to VR Mode (CTL+TAB).

Let me know how it goes!

Without going into too much detail, I am running a Quest 2 on a machine with slightly lower specs than yourself and with Windows 11 and latest Nvidia driver. I use Virtual desktop and Steam VR and am getting consistent and smooth results.

Getting VD and Steam VR setup isn’t a 5 minute job but is definitely worth the effort. Plenty of guides available on how to do this. I used to use Occulus link cable and found performance was way lower than using wireless link.

As just said before, Win 11 is in conflit with oculus drivers. So using Oculus Link or Air Link will give you low performance. I was in win 11 and I rolled back to win 10 and now all work so fine.
But your serious problem is also your PC hardware. Your GPU is very low. A 3050Ti mobile GPU with only 4 Gb of VRAM is not enough for VR.
I fear you will need to tune your VR at very low resolution to get rid of shutters, and low resolution in VR mode will kill your immersion.
Never mind if in 2D screen you have good performance, VR mode need huge graphic power.

I think your graphics card will hold you back a bit, although my card is older I use a 1080ti 11gb and still have issues sometimes running Oculus 2

Somewhen mentioned they felt your video card would hold you back I can say with the exact same setup that’s not the case. Also as mentioned by many before Windows 11 is a gigantic bottleneck with Oculus Quest 2 VR. After rolling back to windows 10 setup was a breeze.