New Update, and yet more major problems

Well I didn’t think it was possible. But Asobo have done it again. I finally updated the game. It was painless. I genuinely thought I was onto a winner.
The main page loaded but to be met with the server down issue. Not a problem . I can wait.
I waited. It came back online. Only the game doesn’t go past the main menu anymore.
Fine. I’ll delete the community folder. Nope. Didn’t work.
I’ll update all my drivers. Nope.
I’ll delete and reinstall the game . After a few hours download, you guessed it. Still doesn’t work.
I’ve tried loading 6 different air craft, only to get stuck on game loading page after the main menu.
I genuinely thought Asobo were on top of this. I’ve supported them and been patient . But this is the last straw. I refuse to waste any more of my time trying to work around a game which is, in my opinion, going backwards.
It’s taken fantastic strides in recent months , to the detriment of graphical quality, but the constant issues after SU is unacceptable. I spend more time getting it to work then flying it.
So enjoy MSFS guys and girls. It has potential for sure, but years down the line. FS2004 it is I guess 🤷

5 Likes

Steam or MS Store?

Your lucky my download has been stalled at 24 gig for 4 hours now I have started and restarted the PC but still no go typical Microsoft

1 Like

Apologies. It is the steam version. I’m frustrated more than anything else. Just seems one problem after another.

2 Likes

Ah ok, I’ve very rarely seen people have issues with the Steam version in fact you may well be the first! Usually the MS Store is the culprit.

1 Like

Steam of MS store. Mine is steam and from Australia, where Broadband is notoriously bad. But it downloads it fine and quickly

Did you get the updates in the content manager as well?
Do you have 3rd party marketplace content installed? Deinstall those and try again.
Did you make changes in the config file manually? Delete it so that it gets reset. When you start the Sim again, it might prompt that is wants to download everything again, but don’t worry, you just have to point MSFS to the correct installation path.

1 Like

Sorry for you man.
Running into many issues too, very poor performances.Would you mind me asking where i can find the community folder for steam instal, the only one i got is in roaming but after deleting still the same.
thx

Dont give up. Did you see the note about server issues earlier today?The servers are now up and running again, give it a try.

It is recommended to have a look to the forum for such notes on update events, even microsoft‘s strong server backbone aches in this scenarios.

I have the same issue, will not even load to the main menu. done the usual.

Steam install here and my experience has, aside from when I cocked-up my swap file (causing a brief spate of CTDs and stuck loading screens) and accidentally wiping the game by doing a Steam validation, been near perfect (I say near just in case I missed something). All updates went without fail - I’ve not always emptied my Community folder prior to upadting either.
Based on my experience with the swap file, I do wonder how many stuck games are related to this.

Well I went extreme. Formatted the SSD ( It’s only used for MSFS ) reinstalled the game over night. Downloaded a few small items for the community folder, I.e pushback helper and FBW A320 and…



It’s working!!
Seems very smooth…so far.
In essence I had to reinstall the game twice , having never touched the CFG files and following advice to delete the community folder etc.
Very strange.
But we shouldn’t have to go through issues after every update. It’s frustrating as hell.

2 Likes

And now the server has gone down again in Australia. No online functionality at all. You couldnt make this up

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.